summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:50:40 +0200
committerStefan Husmann2015-06-09 00:50:40 +0200
commit3c92232b8ba1315e4f3ad1feb928daf8e9e47a9f (patch)
treeca3be4a732fa629d01c363206e180ff50db8b7a9
downloadaur-3c92232b8ba1315e4f3ad1feb928daf8e9e47a9f.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
-rw-r--r--simdock.install13
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab22cd61f24f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = simdock-git
+ pkgdesc = Fast and customizable dockbar.
+ pkgver = 72.20fec28
+ pkgrel = 1
+ url = https://github.com/onli/simdock
+ install = simdock.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = wxgtk2.8
+ depends = libwnck
+ depends = gconf
+ provides = simdock
+ conflicts = simdock
+ source = git://github.com/onli/simdock.git
+ md5sums = SKIP
+
+pkgname = simdock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..894329453a68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: sickhate <sickhate@tux-linux.net>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=simdock-git
+pkgver=72.20fec28
+pkgrel=1
+pkgdesc="Fast and customizable dockbar."
+arch=('i686' 'x86_64')
+url="https://github.com/onli/simdock"
+license=('GPL')
+depends=('wxgtk2.8' 'libwnck' 'gconf')
+provides=('simdock')
+conflicts=('simdock')
+install=simdock.install
+source=("git://github.com/onli/simdock.git")
+_repo=simdock
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_repo}"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${_repo}"
+ sed -i 's+wx-config+wx-config-2.8+' Makefile
+}
+
+build() {
+ cd "$srcdir/${_repo}"
+ make
+}
+
+package() {
+ cd "$srcdir/${_repo}"
+ make DESTDIR="$pkgdir" install
+ rm -rf $pkgdir/usr/local
+}
diff --git a/simdock.install b/simdock.install
new file mode 100644
index 000000000000..bab92327c130
--- /dev/null
+++ b/simdock.install
@@ -0,0 +1,13 @@
+pkgname=simdock
+
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ update-desktop-database -q
+}