summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGlen Dsouza2015-12-12 01:16:00 +0530
committerGlen Dsouza2015-12-12 01:16:00 +0530
commit15e76f4f14a801a14db45a5190d614d479e7ff3e (patch)
tree6b63d704c963b93a021006b11cc84d3bcd3a7f09
parent9f419818d6baa0592dbcbaf65e7f41de124422c5 (diff)
downloadaur-15e76f4f14a801a14db45a5190d614d479e7ff3e.tar.gz
Update dependencies
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddc6853affa9..7207cbd515bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 19:45:56 UTC 2015
pkgbase = simgear-git
pkgdesc = A set of open-source libraries designed to be used as building blocks for quickly assembling 3d simulations, games, and visualization applications.
- pkgver = 20150829
+ pkgver = 20151212
pkgrel = 1
url = http://simgear.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
- makedepends = git
+ makedepends = boost
+ makedepends = cmake
+ makedepends = mesa
+ depends = glu
depends = glut
depends = freealut
depends = plib
depends = openscenegraph
- depends = boost>=1.49
provides = simgear-git
conflicts = simgear
source = git://git.code.sf.net/p/flightgear/simgear
diff --git a/PKGBUILD b/PKGBUILD
index ca27a7d7e43e..57add8209729 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
-# Maintainer: jmf <jmf at mesecons dot net>
-# Contributor: Pascal Groschwitz <p.groschwitz@googlemail.com>
+# Maintainer: Glen Dsouza <glen@teameos.org>
# Contributor: jmf <jmf at mesecons dot net>
+# Contributor: Pascal Groschwitz <p.groschwitz@googlemail.com>
pkgname=simgear-git
-pkgver=20150829
+pkgver=20151212
pkgrel=1
_gitname=simgear
pkgdesc="A set of open-source libraries designed to be used as building blocks for quickly assembling 3d simulations, games, and visualization applications."
arch=('i686' 'x86_64')
url="http://simgear.sourceforge.net/"
license=('GPL')
-depends=('glut' 'freealut' 'plib' 'openscenegraph' 'boost>=1.49')
+depends=('glu' 'glut' 'freealut' 'plib' 'openscenegraph')
optdepends=()
-makedepends=('git')
+makedepends=('boost' 'cmake' 'mesa')
provides=('simgear-git')
conflicts=('simgear')
source=(git://git.code.sf.net/p/flightgear/simgear)
md5sums=('SKIP')
+pkgver() {
+ echo "$(date +"%Y%m%d")"
+}
+
build() {
cd ${srcdir}/${_gitname}
git checkout next