summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemy2016-11-19 20:12:55 +0100
committerRemy2016-11-19 20:12:55 +0100
commit7d1c713f368cea07740685c3f20152f47c61d866 (patch)
treeb025be65aae9f0f7a5281e1e4f63815fafd53d6b
downloadaur-7d1c713f368cea07740685c3f20152f47c61d866.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae0860ae00ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = simh-git
+ pkgdesc = The Computer History Simulation Project
+ pkgver = 4.0.Beta.1.757.gff95fb8
+ pkgrel = 1
+ url = http://simh.trailing-edge.com/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libpcap
+ depends = unzip
+ provides = simh
+ conflicts = simh
+ source = git+https://github.com/simh/simh.git
+ sha512sums = SKIP
+
+pkgname = simh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c670d084ca0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: R. van Elst <https://raymii.org>
+
+pkgname="simh-git"
+pkgver=4.0.Beta.1.757.gff95fb8
+pkgrel=1
+pkgdesc="The Computer History Simulation Project"
+arch=('i686' 'x86_64')
+url="http://simh.trailing-edge.com/"
+license=('MIT')
+depends=('libpcap' 'unzip')
+makedepends=()
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=('git+https://github.com/simh/simh.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ printf "%s" "$(git describe --long --tags | sed 's/v//; s/-/./g')"
+}
+
+build() {
+ cd "${pkgname%-*}"
+ make
+}
+
+package() {
+ cd "$srcdir/simh/BIN"
+ for i in *; do
+ install -D $i "$pkgdir/usr/bin/simh-$i"
+ done
+
+ cd "$srcdir/simh/VAX"
+ mkdir -p "$pkgdir/usr/lib/simh"
+ cp *.bin "$pkgdir/usr/lib/simh"
+}
+
+