summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit9c01a6711af4da1cff71cb46bd4a3a45121ddb69 (patch)
treec6de2665daeeeccf115b74d994f409f69c9ea558
downloadaur-9c01a6711af4da1cff71cb46bd4a3a45121ddb69.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.AURINFO25
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD34
-rw-r--r--simon.install11
4 files changed, 95 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..b6ada0794f9b
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,25 @@
+pkgbase = simon
+ pkgdesc = Open-source speech recognition program for replacing mouse and keyboard
+ pkgver = 0.4.1
+ pkgrel = 3
+ url = http://simon.kde.org/
+ install = simon.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = automoc4
+ makedepends = cmake
+ makedepends = flex
+ makedepends = docbook-xml
+ makedepends = boost
+ depends = portaudio
+ depends = qwt
+ depends = kdebase-runtime
+ depends = kdepimlibs
+ optdepends = htk: create and modify the speech models
+ optdepends = julius: for speech recognition
+ source = http://download.kde.org/stable/simon/0.4.1/src/simon-0.4.1.tar.bz2
+ sha256sums = 8d55bc3f607a89e15efd51b844d93daf67d9967ad243f54efae324754859342d
+
+pkgname = simon
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6ada0794f9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = simon
+ pkgdesc = Open-source speech recognition program for replacing mouse and keyboard
+ pkgver = 0.4.1
+ pkgrel = 3
+ url = http://simon.kde.org/
+ install = simon.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = automoc4
+ makedepends = cmake
+ makedepends = flex
+ makedepends = docbook-xml
+ makedepends = boost
+ depends = portaudio
+ depends = qwt
+ depends = kdebase-runtime
+ depends = kdepimlibs
+ optdepends = htk: create and modify the speech models
+ optdepends = julius: for speech recognition
+ source = http://download.kde.org/stable/simon/0.4.1/src/simon-0.4.1.tar.bz2
+ sha256sums = 8d55bc3f607a89e15efd51b844d93daf67d9967ad243f54efae324754859342d
+
+pkgname = simon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..993f4c5fd216
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archinux.org>
+# Contributor: Jameson Pugh <imntreal@gmail.com>
+# Contributor : Sascha Pfau <MrPeacock@gmail.com>
+
+pkgname=simon
+pkgver=0.4.1
+pkgrel=3
+pkgdesc="Open-source speech recognition program for replacing mouse and keyboard"
+arch=('i686' 'x86_64')
+url="http://simon.kde.org/"
+license=('GPL')
+depends=('portaudio' 'qwt' 'kdebase-runtime' 'kdepimlibs')
+makedepends=('automoc4' 'cmake' 'flex' 'docbook-xml' 'boost')
+optdepends=('htk: create and modify the speech models'
+ 'julius: for speech recognition')
+install=$pkgname.install
+source=(http://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.bz2)
+sha256sums=('8d55bc3f607a89e15efd51b844d93daf67d9967ad243f54efae324754859342d')
+
+build() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ mkdir -p build
+ cd build
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DQT_QMAKE_EXECUTABLE=qmake-qt4 ..
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver/build
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/simon.install b/simon.install
new file mode 100644
index 000000000000..e70c054ec6ad
--- /dev/null
+++ b/simon.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}