summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsimona2018-11-30 00:40:56 +0100
committersimona2018-11-30 00:40:56 +0100
commit9213290d55162c584c8d5360819a3473f0c5cafe (patch)
tree726c257b4f4d419078bc6abd17a0244bcbf1bd37
parent150a7625e74c19119e4de1d54e6d2bd199f4ab24 (diff)
downloadaur-9213290d55162c584c8d5360819a3473f0c5cafe.tar.gz
fix
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD6
-rwxr-xr-xmacinstall11
-rw-r--r--macinstall.110
4 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd3e3c357128..0fb1391b594d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = simonascripts
pkgdesc = Bash unique command for mount image files (iso, vms, crypto, squashfs), detect pendrive device name, list all kernels, list all i/o schedulers, copy install files.
- pkgver = 0.0.17
+ pkgver = 0.0.19
pkgrel = 1
changelog = simonascripts.changelog
arch = any
@@ -36,10 +36,10 @@ pkgbase = simonascripts
md5sums = 40ef9e0d1831cc1865208bf52eaa2cef
md5sums = 331e7dbdd1adbed7beaad5975a368d91
md5sums = 3189eb5ae50a9ddce43c8820c35ba2b0
- md5sums = 0da0f06f52839ae85aa79d3e2a2bd069
+ md5sums = 546c55ce5f94a4039f609dc6f7c8a4fe
md5sums = 895210bbf0e6c16c6df7437eb3489ac1
md5sums = 261d420ae53438b3fadda33059686a33
- md5sums = e95fa305e9120ed71c74ac5925811f10
+ md5sums = f3197a3b2aad5cb79b5dbab0d35fd0f9
pkgname = simonascripts
diff --git a/PKGBUILD b/PKGBUILD
index 0c25665f26a0..24b566d58379 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Simona <simona.pisano[at]gmail[dot]com>
pkgname=simonascripts
-pkgver=0.0.17
+pkgver=0.0.19
pkgrel=1
pkgdesc="Bash unique command for mount image files (iso, vms, crypto, squashfs), detect pendrive device name, list all kernels, list all i/o schedulers, copy install files."
@@ -41,10 +41,10 @@ md5sums=('3f5599c3588f01b625aa9feb0a0e8b99'
'40ef9e0d1831cc1865208bf52eaa2cef'
'331e7dbdd1adbed7beaad5975a368d91'
'3189eb5ae50a9ddce43c8820c35ba2b0'
- '0da0f06f52839ae85aa79d3e2a2bd069'
+ '546c55ce5f94a4039f609dc6f7c8a4fe'
'895210bbf0e6c16c6df7437eb3489ac1'
'261d420ae53438b3fadda33059686a33'
- 'e95fa305e9120ed71c74ac5925811f10')
+ 'f3197a3b2aad5cb79b5dbab0d35fd0f9')
package() {
cd "$srcdir"
diff --git a/macinstall b/macinstall
index f4f2bfc4cda6..277fbb9ac914 100755
--- a/macinstall
+++ b/macinstall
@@ -70,11 +70,12 @@ Summary usage
Option parameters
--help -h -> this help page
-i --info or blank -> who am i looking semaphore file
- --version -> version
+ --version -> output version information and exit
-y --ask-confirm -> ask confirm before proceeed
---this-is-not-an-exercise -> force real work. without this
none is really done. this is a
secure check.
+ ---no-test -> use dest / instead $USER/test
Path used
/etc/macinstall.d -> contains all single
@@ -129,12 +130,14 @@ fi
runLocalImport=false
[[ $2 == "local-import" ]] && runLocalImport=true
+flagNoTest=false
flagForceRealWork=false
flagAskConfirm=false
while [ $# -ne 0 ] ; do
case $1 in
-y|--ask-confirm) flagAskConfirm=true ;;
---this-is-not-an-exercise) flagForceRealWork=true;;
+ ---no-test) flagNoTest=true;;
*) ;;
esac
shift
@@ -168,12 +171,10 @@ filename_cfg="macinstall.conf"
#path_dest must be '/' terminated
#path_dest="/home/simona/My Work/my-pkg simonascripts/root-test/"
path_dest="$HOME/test/"
-#path_dest="/"
+[[ "$flagForceRealWork" == true ]] && { echo "$WARN Using real path / for destination..."; path_dest="/"; }
#if last char is not '/' add it
[[ ${path_dest:${#path_dest}-1:1} != "/" ]] && path_dest="$path_dest/"
-
-
postfix_bak_file_name=".bak"
#cfg related
@@ -266,7 +267,7 @@ fi
if [[ "$flagForceRealWork" == true ]] ; then
echo -e "$WARN Warning: using REAL path. This is not a simulation. I can damage system."
- echo "Dest dir used is '$path_dest'. (absolute path starting with '/' are fixed removing it)."
+ echo "Dest dir used is '$path_dest'."
echo -n "Continue? (Y/N): "; read ask
[[ ! $ask =~ ^(yes|y|YES|y|s|S|si|SI|sì)$ ]] && { echo "Exit forced by user."; exit 0; }
fi
diff --git a/macinstall.1 b/macinstall.1
index b7e0d86cd181..bff5575b0b2d 100644
--- a/macinstall.1
+++ b/macinstall.1
@@ -15,7 +15,7 @@ Bash script to manage different install files (if you clone smae install on more
who am i looking semaphore file
--version
- version
+ output version information and exit
-y --ask-confirm
ask confirm before proceeed
@@ -23,17 +23,15 @@ Bash script to manage different install files (if you clone smae install on more
---this-is-not-an-exercise
force real work. without this none is really done. this is a secure check.
+---no-test
+ use dest / instead $USER/test
+
-h, --help
display this help and exit
---force-iso-stdmount
- force in iso sudo mount 'mount -o loop' instead 'fuseiso'
-
-y, --ask-confirm
confirm before execute
---version
- output version information and exit
.SH PATH USED
/etc/macinstall.d
contains all single install related files (example fstab grub.cfg machine-id...)