summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsimona2018-11-25 17:38:57 +0100
committersimona2018-11-25 17:38:57 +0100
commita4d3b0833d6f983216fffe6f00ce756606b688c8 (patch)
tree9865fe89967eda7243381ae7a7ea492cf8f9b530
parentb583ae52f4aa6be344ff073d0e19675b24be69d5 (diff)
downloadaur-a4d3b0833d6f983216fffe6f00ce756606b688c8.tar.gz
better -h help text
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD8
-rwxr-xr-ximage-mount42
-rwxr-xr-ximage-umount32
4 files changed, 62 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aac99990f26b..123392c993b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = simonascripts
pkgdesc = Bash unique command for mount image files (iso, vms, crypto, squashfs), detect pendrive device name, list all kernels, list all i/o schedulers.
- pkgver = 0.0.4
- pkgrel = 2
+ pkgver = 0.0.5
+ pkgrel = 1
arch = any
license = GPL3
depends = bash
@@ -16,8 +16,8 @@ pkgbase = simonascripts
source = pendrive-detect
source = simona-scripts
md5sums = 3f5599c3588f01b625aa9feb0a0e8b99
- md5sums = b36b71c82c7a8baf4eff72af67ed50be
- md5sums = a874f35365c7c302c3db3cb8ba436a5b
+ md5sums = f2f968bde9938365374ad7ee9c9c993d
+ md5sums = b9ab4d94a9a7a5003c86d5f3f067372c
md5sums = c58f5737bb41c8af2bff7dd24a3d2723
md5sums = 6379f2d72a7f197961f7d10bf428d667
md5sums = ef7511e134eb386162c3c0646d6c590a
diff --git a/PKGBUILD b/PKGBUILD
index 7076db3d1b0e..c6ef3511ffad 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Simona <simona.pisano[at]gmail[dot]com>
pkgname=simonascripts
-pkgver=0.0.4
-pkgrel=2
+pkgver=0.0.5
+pkgrel=1
pkgdesc="Bash unique command for mount image files (iso, vms, crypto, squashfs), detect pendrive device name, list all kernels, list all i/o schedulers."
arch=('any')
@@ -21,8 +21,8 @@ source=( "boot-kernel-list"
"simona-scripts" )
md5sums=('3f5599c3588f01b625aa9feb0a0e8b99'
- 'b36b71c82c7a8baf4eff72af67ed50be'
- 'a874f35365c7c302c3db3cb8ba436a5b'
+ 'f2f968bde9938365374ad7ee9c9c993d'
+ 'b9ab4d94a9a7a5003c86d5f3f067372c'
'c58f5737bb41c8af2bff7dd24a3d2723'
'6379f2d72a7f197961f7d10bf428d667'
'ef7511e134eb386162c3c0646d6c590a')
diff --git a/image-mount b/image-mount
index a3ea6ea3c25c..4c526e072f12 100755
--- a/image-mount
+++ b/image-mount
@@ -49,16 +49,38 @@ allow_formats_iso="iso nrg bin img mdf"
allow_formats_crypto="tcrypt plain luks luks1 luks2 loopaes"
if [[ $1 == "-h" || $1 == "--help" ]] ; then
- echo "Sintax 1: image-mount [--help|-h]"
- echo "Sintax 2: image-mount [path/]file-name.ext] [format | part#] [mount-path | part#] [--force-iso-stdmount]"
- echo " --force-iso-stdmount -> forse in iso sudo mount 'mount -o loop' instead 'fuseiso'"
- echo "Warning 1: part# in in format 0-9 with one integer value"
- echo "Warning 2: format must be explicily specified if file extension do not say itself the correct format."
- echo "Warning 3: all parameters are case sensitive."
- echo "Default: image-mount image.raw raw 0 \${HOME}/mount/image"
- echo "Minimal: image-mount file.ext"
- echo "Typical: image-mount file.ext 2"
- echo "Allowed formats: ${allow_formats} ${allow_formats_iso} ${allow_formats_crypto} sqhashfs"
+ cat << EOF
+image-mount command help
+
+Usage
+ image-mount [--help|-h]"
+ image-mount [path/]file-name.ext] [format | part#] [mount-path | part#] [--force-iso-stdmount]
+ --force-iso-stdmount -> force in iso sudo mount 'mount -o loop' instead 'fuseiso'
+
+Warnings
+ 1) part# in in format 0-9 with one integer value
+ 2) format must be explicily specified if file extension do not say itself the correct format.
+ 3) all parameters are case sensitive.
+
+Default pars:
+ image-mount image.raw raw 0 \${HOME}/mount/image
+Minimal usate:
+ image-mount file.ext
+Common usage:
+ image-mount file.ext 2
+
+Full allowed format list (with 'more partitions inside' supported)
+----------------------------------------------------------------------------------------------------
+Virtual images allowed ('qemu' for this function package required):
+ ${allow_formats}
+Iso images (fuse standard mount or optional 'fuseiso' package required):
+ ${allow_formats_iso}
+Crypto images ('cryptsetup' for this function package is required):
+ ${allow_formats_crypto}
+Squash readonly file (can ben modified, saved on umount) (package 'squashfs-tools' required):
+ sqhashfs
+EOF
+
exit 0
fi
diff --git a/image-umount b/image-umount
index 88b6195d1f43..7b78ed7b348c 100755
--- a/image-umount
+++ b/image-umount
@@ -14,16 +14,28 @@ ERR="\E[31;40m[OK]${EchoReset}"
[[ $1 == "" ]] && exit 0
if [[ $1 == "-h" || $1 == "--help" ]] ; then
- echo "Sintax 1: image-umount [--help|-h]"
- echo "Sintax 2: image-umount reset [path] (try)"
- echo "Sintax 3: image-umount image.ext [format] [mount-path] [--force-iso-stdmount]"
- echo " --force-iso-stdmount -> force in iso mount 'mount -o loop' instead 'fuseiso'"
- echo "Warning: format must be explicily specified if file extension do not say itself the correct format."
- echo "Warning: all parameters are case sensitive."
- echo "Default: image-umount image.raw raw 0 \$HOME/mount/image"
- echo "Minimal: image-umount file.ext"
- echo "Typical: image-umount file.ext 2"
- echo "Allowed formats: $allow_formats $allow_formats_iso $allow_formats_crypto squashfs"
+ cat << EOF
+image-umount command help
+
+More details and supported formats are supplied inside 'image-mount -h' script.
+
+Usage
+ image-umount [--help|-h]
+ image-umount reset [path] (try)
+ image-umount image.ext [format] [mount-path] [--force-iso-stdmount]
+ --force-iso-stdmount -> force in iso mount 'mount -o loop' instead 'fuseiso'
+
+Warning:
+ 1) format must be explicily specified if file extension do not say itself the correct format.
+ 2) Warning: all parameters are case sensitive.
+
+Default parameters:
+ image-umount image.raw raw 0 \$HOME/mount/image
+Minimal usage:
+ image-umount file.ext
+Typical usage:
+ image-umount file.ext 2
+EOF
exit 0
fi