summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsimona2018-12-02 10:39:35 +0100
committersimona2018-12-02 10:39:35 +0100
commitd23f5f9d35e10099383c940fe87cfaa6d1c1661c (patch)
tree8b6277e09063ddf887423d5ed37870acfdf0939f
parent9213290d55162c584c8d5360819a3473f0c5cafe (diff)
downloadaur-d23f5f9d35e10099383c940fe87cfaa6d1c1661c.tar.gz
fix
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD4
-rwxr-xr-xmacinstall41
3 files changed, 21 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fb1391b594d..e853171149f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = simonascripts
pkgdesc = Bash unique command for mount image files (iso, vms, crypto, squashfs), detect pendrive device name, list all kernels, list all i/o schedulers, copy install files.
- pkgver = 0.0.19
+ pkgver = 0.0.20
pkgrel = 1
changelog = simonascripts.changelog
arch = any
@@ -36,7 +36,7 @@ pkgbase = simonascripts
md5sums = 40ef9e0d1831cc1865208bf52eaa2cef
md5sums = 331e7dbdd1adbed7beaad5975a368d91
md5sums = 3189eb5ae50a9ddce43c8820c35ba2b0
- md5sums = 546c55ce5f94a4039f609dc6f7c8a4fe
+ md5sums = 11525ff54253381211531dbb13f761fd
md5sums = 895210bbf0e6c16c6df7437eb3489ac1
md5sums = 261d420ae53438b3fadda33059686a33
md5sums = f3197a3b2aad5cb79b5dbab0d35fd0f9
diff --git a/PKGBUILD b/PKGBUILD
index 24b566d58379..4e2f45b64b40 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Simona <simona.pisano[at]gmail[dot]com>
pkgname=simonascripts
-pkgver=0.0.19
+pkgver=0.0.20
pkgrel=1
pkgdesc="Bash unique command for mount image files (iso, vms, crypto, squashfs), detect pendrive device name, list all kernels, list all i/o schedulers, copy install files."
@@ -41,7 +41,7 @@ md5sums=('3f5599c3588f01b625aa9feb0a0e8b99'
'40ef9e0d1831cc1865208bf52eaa2cef'
'331e7dbdd1adbed7beaad5975a368d91'
'3189eb5ae50a9ddce43c8820c35ba2b0'
- '546c55ce5f94a4039f609dc6f7c8a4fe'
+ '11525ff54253381211531dbb13f761fd'
'895210bbf0e6c16c6df7437eb3489ac1'
'261d420ae53438b3fadda33059686a33'
'f3197a3b2aad5cb79b5dbab0d35fd0f9')
diff --git a/macinstall b/macinstall
index 277fbb9ac914..e5cf0db368cb 100755
--- a/macinstall
+++ b/macinstall
@@ -160,31 +160,9 @@ ERR="\E[31;40m[ERR]${EchoReset}"
#echo -e "$OK $WARN $ERR"
#path_cfg must be '/' terminated
-#path_cfg="../etc-macinstall.d/"
-path_cfg="/etc/macinstall.d/"
-#if last char is not '/' add it
-[[ ${path_cfg:${#path_cfg}-1:1} != "/" ]] && path_cfg="$path_cfg/"
-
-
filename_cfg="macinstall.conf"
-
-#path_dest must be '/' terminated
-#path_dest="/home/simona/My Work/my-pkg simonascripts/root-test/"
-path_dest="$HOME/test/"
-[[ "$flagForceRealWork" == true ]] && { echo "$WARN Using real path / for destination..."; path_dest="/"; }
-#if last char is not '/' add it
-[[ ${path_dest:${#path_dest}-1:1} != "/" ]] && path_dest="$path_dest/"
-
-postfix_bak_file_name=".bak"
-
-#cfg related
-prop_cfg_file_copy_num="CopyFilesNum"
-prop_cfg_dir_copy_num="CopyDirectoriesNum"
-prop_cfg_file_copy="CopyFile"
-prop_cfg_dir_copy="CopyDirectory"
-prop_cfg_write_sem="WriteSemaphore"
-prop_cfg_read_sem="AllowOnlyIfPreviousMacIs"
-
+path_cfg="/etc/macinstall.d/"
+[[ ${path_cfg:${#path_cfg}-1:1} != "/" ]] && path_cfg="$path_cfg/" #if last char is not '/' add it
if [[ ! -d $path_cfg ]] ; then
mkdir -p $path_cfg
[[ $? -ne 0 ]] && { echo -e "$ERR Fail '$path_cfg' mkdir cmd creation !!"; exit 1; }
@@ -194,11 +172,26 @@ if [[ ! -r $path_cfg$filename_cfg ]] ; then
[[ $? -ne 0 ]] && { echo -e "$ERR Fail '$path_cfg$filename_cfg' touch cmd creation !!"; exit 1; }
fi
+#path_dest must be '/' terminated
+path_dest="$HOME/test/"
+[[ "$flagNoTest" == true ]] && { echo "$WARN Using real path / for destination..."; path_dest="/"; }
+[[ ${path_dest:${#path_dest}-1:1} != "/" ]] && path_dest="$path_dest/" #if last char is not '/' add it
if [[ ! -d $path_dest ]] ; then
+ [[ ${path_dest:0:5} == "/home" && ! -d "/home" ]] && { echo "$ERR Path '/home' missing. (For / use) Exit."; exit 1; }
mkdir -p $path_dest
[[ $? -ne 0 ]] && { echo -e "$ERR Fail $path_dest mkdir cmd creation !!"; exit 1; }
fi
+postfix_bak_file_name=".bak"
+
+#cfg related
+prop_cfg_file_copy_num="CopyFilesNum"
+prop_cfg_dir_copy_num="CopyDirectoriesNum"
+prop_cfg_file_copy="CopyFile"
+prop_cfg_dir_copy="CopyDirectory"
+prop_cfg_write_sem="WriteSemaphore"
+prop_cfg_read_sem="AllowOnlyIfPreviousMacIs"
+
if [[ "$flagAskConfirm" == true ]] ; then
echo -n "Continue? (Y/N): "; read ask
[[ ! $ask =~ ^(yes|y|YES|y|s|S|si|SI|sì)$ ]] && { echo "Exit forced by user."; exit 0; }