summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlemens Schölhorn2017-06-20 20:14:32 +0200
committerKlemens Schölhorn2017-06-20 20:14:32 +0200
commit1bba07cf0950565da59af5ebff04ca4d70d106b9 (patch)
tree9d1fa60d282936c32bdd0849788c64f4610592c0
parentaf47302dd106b775269f24ffb837620b9ec88fe4 (diff)
downloadaur-1bba07cf0950565da59af5ebff04ca4d70d106b9.tar.gz
Revert "Add support for python-acme 0.15.0"
Patch is now upstream. This reverts commit af47302dd106b775269f24ffb837620b9ec88fe4.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--acme_0.15.patch29
3 files changed, 4 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6cddb285b2a..a9be60c3e9a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = simp_le-git
pkgdesc = Simple Let's Encrypt client.
- pkgver = 0.2.0.r10.gd88af9d
+ pkgver = 0.2.0.r15.g09e5226
pkgrel = 1
epoch = 1
url = https://github.com/zenhack/simp_le
@@ -18,9 +18,7 @@ pkgbase = simp_le-git
provides = simp_le
conflicts = simp_le
source = simp_le::git+https://github.com/zenhack/simp_le.git
- source = acme_0.15.patch
md5sums = SKIP
- md5sums = 718c7d24821a24f92f7fa26401635f8c
pkgname = simp_le-git
diff --git a/PKGBUILD b/PKGBUILD
index c1e2cc7b8443..f1c038bfbe03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=simp_le-git
_pkgname=simp_le
-pkgver=0.2.0.r10.gd88af9d
+pkgver=0.2.0.r15.g09e5226
pkgrel=1
epoch=1
pkgdesc="Simple Let's Encrypt client."
@@ -22,21 +22,14 @@ depends=('ca-certificates'
makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}"::"git+https://github.com/zenhack/simp_le.git"
- 'acme_0.15.patch')
-md5sums=('SKIP'
- '718c7d24821a24f92f7fa26401635f8c')
+source=("${_pkgname}"::"git+https://github.com/zenhack/simp_le.git")
+md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "${srcdir}/${_pkgname}"
- patch -Np1 -i "${srcdir}/acme_0.15.patch"
-}
-
package() {
cd "${srcdir}/${_pkgname}"
diff --git a/acme_0.15.patch b/acme_0.15.patch
deleted file mode 100644
index ea1574b26322..000000000000
--- a/acme_0.15.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 7d3a48d..a543bfb 100644
---- a/setup.py
-+++ b/setup.py
-@@ -8,7 +8,7 @@ here = os.path.abspath(os.path.dirname(__file__))
- readme = codecs.open(os.path.join(here, 'README.rst'), encoding='utf-8').read()
-
- install_requires = [
-- 'acme>=0.11,<0.12',
-+ 'acme>=0.15,<0.16',
- 'cryptography',
- 'pyOpenSSL',
- 'pytz',
-diff --git a/simp_le.py b/simp_le.py
-index 4a6e2af..ecafda8 100755
---- a/simp_le.py
-+++ b/simp_le.py
-@@ -1230,9 +1230,8 @@ def registered_client(args, existing_account_key):
- new_reg = messages.NewRegistration.from_data(email=args.email)
- try:
- regr = client.register(new_reg)
-- except messages.Error as error:
-- if error.detail != 'Registration key is already in use':
-- raise
-+ except acme_errors.ConflictError as error:
-+ logger.debug('Client already registered: %s', error.location)
- else:
- if regr.terms_of_service is not None:
- tos_hash = sha256_of_uri_contents(regr.terms_of_service)