summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlemens Schölhorn2019-06-27 22:58:53 +0200
committerKlemens Schölhorn2019-06-27 22:58:53 +0200
commit1f199d3b6a6c190eec0b7bfcc57c3c5b5101f3ae (patch)
tree7da5576bb2e139b715edba9c565e87705885b496
parentf6145c96d8e27871ee9d6b4bd0e4afeb9231ad4b (diff)
downloadaur-1f199d3b6a6c190eec0b7bfcc57c3c5b5101f3ae.tar.gz
Update to 0.15.0, python-acme 0.35.0
Note that there are several breaking changes [1], including removing the `-f external.sh` feature and the need to now also save the account_reg.json file. [1]: https://github.com/zenhack/simp_le#change-log
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--remove-deps-version-bounds.patch2
3 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7c9adce395d..2832bd2b3fb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = simp_le-git
pkgdesc = Simple Let's Encrypt client.
- pkgver = 0.10.0.r3.gd37761b
+ pkgver = 0.15.0.r0.gec60f7d
pkgrel = 1
epoch = 1
url = https://github.com/zenhack/simp_le
@@ -20,7 +20,7 @@ pkgbase = simp_le-git
source = simp_le::git+https://github.com/zenhack/simp_le.git
source = remove-deps-version-bounds.patch
sha256sums = SKIP
- sha256sums = 475836e8766559d61d34be9a49760eeae6bb42665460ee07b7b3ce509512f4ac
+ sha256sums = d3428326027fddfe58978e007234abd34b00a24e963859a79d0af02761a2bcd9
pkgname = simp_le-git
diff --git a/PKGBUILD b/PKGBUILD
index a5d89f5c3adf..4fcfc2469a05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=simp_le-git
_pkgname=simp_le
-pkgver=0.10.0.r3.gd37761b
+pkgver=0.15.0.r0.gec60f7d
pkgrel=1
epoch=1
pkgdesc="Simple Let's Encrypt client."
@@ -25,7 +25,7 @@ conflicts=("${_pkgname}")
source=("${_pkgname}"::"git+https://github.com/zenhack/simp_le.git"
'remove-deps-version-bounds.patch')
sha256sums=('SKIP'
- 'd951bbf695d49ceeebc52af86b14e36dd08a69d3aa872df5fd55d4f4196e2b95')
+ 'd3428326027fddfe58978e007234abd34b00a24e963859a79d0af02761a2bcd9')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -42,7 +42,4 @@ package() {
cd "${srcdir}/${_pkgname}"
python setup.py install --root="$pkgdir/" --optimize=1
-
- install -d "${pkgdir}/usr/share/${_pkgname}"
- cp -dr --no-preserve=ownership examples/ "${pkgdir}/usr/share/${_pkgname}"
}
diff --git a/remove-deps-version-bounds.patch b/remove-deps-version-bounds.patch
index 988a0891b930..0057d95e329a 100644
--- a/remove-deps-version-bounds.patch
+++ b/remove-deps-version-bounds.patch
@@ -17,7 +17,7 @@ diff -u -r a/setup.py b/setup.py
- # * https://github.com/pypa/pip/issues/988
- 'idna<2.8',
-
-- 'acme>=0.34.2,<0.35',
+- 'acme>=0.35,<0.36',
+ 'acme',
'cryptography',
# formerly known as acme.jose: