summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlemens Schölhorn2017-06-19 18:46:20 +0200
committerKlemens Schölhorn2017-06-19 19:03:56 +0200
commite92816f526a67d744f4851814d2f0cddf67d24e2 (patch)
tree0610b424b2a94eda233e33b3afd36727e917fe08
parentfa65d405efef8c62a83302c3d3756f3ef1c9895c (diff)
downloadaur-e92816f526a67d744f4851814d2f0cddf67d24e2.tar.gz
Use setup.py (setuptools) instead of a manual installation
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f22ed630bf07..a0f8b2fbcae0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,8 +33,8 @@ pkgver() {
package() {
cd "${srcdir}/${_pkgname}"
- install -Dp -m755 simp_le.py "${pkgdir}"/usr/share/"${_pkgname}"/simp_le.py
- cp -r examples/ "${pkgdir}"/usr/share/"${_pkgname}"/
- install -d "${pkgdir}"/usr/bin/
- ln -s /usr/share/${_pkgname}/simp_le.py "${pkgdir}"/usr/bin/simp_le
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -d "${pkgdir}/usr/share/${_pkgname}"
+ cp -dr --no-preserve=ownership examples/ "${pkgdir}/usr/share/${_pkgname}"
}