summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHong Shick Pak2015-07-13 01:56:16 -0700
committerHong Shick Pak2015-07-13 01:56:29 -0700
commitb5729964b4a7805c512928622d60475109745f43 (patch)
tree615441cb3a0da8bb0d0514b1e75ffbd0bcc229fa
downloadaur-b5729964b4a7805c512928622d60475109745f43.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
-rw-r--r--simpfand-git.install26
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29c1eb03a0b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = simpfand-git
+ pkgdesc = A simple fan control daemon for ThinkPads
+ pkgver = v4.2.9.gaa475fc
+ pkgrel = 1
+ url = http://github.com/hspak/simpfand
+ install = simpfand-git.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ provides = simpfand
+ conflicts = simpfand
+ source = git://github.com/hspak/simpfand
+ md5sums = SKIP
+
+pkgname = simpfand-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e00ba473e40b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Hong Shick Pak <hong@hspak.com>
+
+pkgname=simpfand-git
+pkgver=v4.2.9.gaa475fc
+pkgrel=1
+pkgdesc="A simple fan control daemon for ThinkPads"
+arch=('i686' 'x86_64')
+url="http://github.com/hspak/simpfand"
+license=('MIT')
+depends=()
+makedepends=('git')
+conflicts=('simpfand')
+provides=('simpfand')
+source=("git://github.com/hspak/simpfand")
+install=simpfand-git.install
+md5sums=('SKIP')
+
+pkgver() {
+ cd 'simpfand'
+ git describe | sed 's/-/./g'
+}
+
+build() {
+ make -C simpfand
+}
+
+package() {
+ make -C simpfand PREFIX=/usr DESTDIR="$pkgdir" install
+ install -D -m644 "${srcdir}/simpfand/simpfand.service" "${pkgdir}/usr/lib/systemd/system/simpfand.service"
+ install -D -m755 "${srcdir}/simpfand/restart-simpfand.sh" "${pkgdir}/usr/lib/systemd/system-sleep/restart-simpfand.sh"
+
+ # license
+ install -D -m644 "${srcdir}/simpfand/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ft=sh syn=sh et
diff --git a/simpfand-git.install b/simpfand-git.install
new file mode 100644
index 000000000000..76c72099994a
--- /dev/null
+++ b/simpfand-git.install
@@ -0,0 +1,26 @@
+post_install() {
+ cat << _EOF
+
+ Simpfand can only work if you have enabled the
+ fan control option in the thinkpad_acpi module.
+ Create a file in /etc/modprobe.d/ and append:
+
+ options thinkpad_acpi fan_control=1
+
+ An example config file is located in:
+ /usr/share/doc/simpfand/simpfand.conf
+
+_EOF
+}
+
+post_upgrade() {
+ cat << _EOF
+
+ Simpfand expects a config file in:
+
+ /etc/simpfand.conf
+
+ An _updated_ example config file is located in:
+ /usr/share/doc/simpfand/simpfand.conf
+_EOF
+}