summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2021-05-25 23:07:52 +0000
committerBalló György2021-05-25 23:07:52 +0000
commitbfaaef186ef9229b066bc008e66543aea5018674 (patch)
tree5dac884c4166cec077214c11bcdce60aaf613d96
downloadaur-bfaaef186ef9229b066bc008e66543aea5018674.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..779f8d3b242d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = simple-diary-gtk
+ pkgdesc = Simple and lightweight diary app
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/johan-bjareholt/simple-diary-gtk
+ arch = x86_64
+ license = GPL3
+ makedepends = appstream-glib
+ makedepends = meson
+ depends = libhandy
+ depends = md4c
+ depends = webkit2gtk
+ source = https://github.com/johan-bjareholt/simple-diary-gtk/archive/v0.2.1/simple-diary-gtk-0.2.1.tar.gz
+ sha256sums = 4b51b1b0f4d2c1607e034a6037cad94d34b91256a17bb946a1d4889dae95936d
+
+pkgname = simple-diary-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d72aef2fe57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=simple-diary-gtk
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='Simple and lightweight diary app'
+arch=('x86_64')
+url='https://github.com/johan-bjareholt/simple-diary-gtk'
+license=('GPL3')
+depends=('libhandy' 'md4c' 'webkit2gtk')
+makedepends=('appstream-glib' 'meson')
+source=("https://github.com/johan-bjareholt/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('4b51b1b0f4d2c1607e034a6037cad94d34b91256a17bb946a1d4889dae95936d')
+
+build() {
+ arch-meson $pkgname-$pkgver build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}