summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2018-04-13 22:20:13 +0200
committerDario Ostuni2018-04-13 22:20:13 +0200
commit5fafa69c6204bdae6392061c605117a815299952 (patch)
tree6927f6c494bd42fe4a58e79e70fc961592cff205
downloadaur-5fafa69c6204bdae6392061c605117a815299952.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c484ddc2b47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Apr 13 20:20:06 UTC 2018
+pkgbase = simple-http-server
+ pkgdesc = Simple http server in Rust
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = https://github.com/TheWaWaR/simple-http-server
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = cargo
+ source = https://crates.io/api/v1/crates/simple-http-server/0.4.5/download
+ sha384sums = 5e228480c3e86a0f4ed4e95a5019c101ea2497ad194364a9c69d8475e81bf6024b47e071d8e5e03782998e6e706fba27
+
+pkgname = simple-http-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0f52f34c885
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dario Ostuni <dario.ostuni@gmail.com>
+
+pkgname=simple-http-server
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="Simple http server in Rust"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/TheWaWaR/simple-http-server"
+license=('MIT')
+depends=()
+makedepends=('cargo')
+options=()
+source=("https://crates.io/api/v1/crates/${pkgname}/${pkgver}/download")
+sha384sums=('5e228480c3e86a0f4ed4e95a5019c101ea2497ad194364a9c69d8475e81bf6024b47e071d8e5e03782998e6e706fba27')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}