summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2024-02-17 13:22:44 +0100
committerMattias Andrée2024-02-17 13:22:44 +0100
commitcf0abddf68bc32792d72b5c1b8b17f1f685e7e16 (patch)
tree8bb2bbf4861cae4f7cb18e3c595d39ec2984dd94
parentb3f3ba7d6b3813477735b7510701bbbebec07cdd (diff)
downloadaur-cf0abddf68bc32792d72b5c1b8b17f1f685e7e16.tar.gz
Update to 12
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a33fc710c09..7b22229aa51b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = simple-icon-theme
pkgdesc = A very simple icon theme
- pkgver = 11
+ pkgver = 12
pkgrel = 1
url = https://codeberg.org/maandree/simple-icon-theme
arch = any
license = custom:ISC
makedepends = librsvg
depends = gtk-update-icon-cache
- source = simple-icon-theme-11.tar.gz::https://codeberg.org/maandree/simple-icon-theme/archive/11.tar.gz
- sha512sums = 536269b2453a997fb01c879978b6045be776c5893ca32bcca0a790cbaf4cd414608adedb3c6015243db7e5b4809eb750ca15ebccbd540a46c8bf959d03e8f2d7
+ source = simple-icon-theme-12.tar.gz::https://codeberg.org/maandree/simple-icon-theme/archive/12.tar.gz
+ sha512sums = 69ec5a33c489dc8420b2a3e542ff88dd025d768ba0883cfd9ef4c89bc8c7f4cfc4601cca2f949db09c88a000e5aeabd1e691b72978ea973b92b071140d6fc509
pkgname = simple-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index 16099e975450..460a4827c712 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
pkgname=simple-icon-theme
-pkgver=11
+pkgver=12
pkgrel=1
pkgdesc='A very simple icon theme'
url='https://codeberg.org/maandree/simple-icon-theme'
@@ -10,14 +10,19 @@ license=('custom:ISC')
depends=(gtk-update-icon-cache)
makedepends=(librsvg)
source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
-sha512sums=(536269b2453a997fb01c879978b6045be776c5893ca32bcca0a790cbaf4cd414608adedb3c6015243db7e5b4809eb750ca15ebccbd540a46c8bf959d03e8f2d7)
+sha512sums=(69ec5a33c489dc8420b2a3e542ff88dd025d768ba0883cfd9ef4c89bc8c7f4cfc4601cca2f949db09c88a000e5aeabd1e691b72978ea973b92b071140d6fc509)
build () {
cd "$srcdir/simple-icon-theme"
- make -j all-fast PREFIX=/usr
+ make -j PREFIX=/usr all-fast
+}
+
+check () {
+ cd "$srcdir/simple-icon-theme"
+ make check
}
package () {
cd "$srcdir/simple-icon-theme"
- make install PREFIX=/usr DESTDIR="$pkgdir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
}