summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-19 15:46:58 +0800
committerzxp198210052024-01-19 15:46:58 +0800
commit702fc2299752cb9febac4f5d54e549afdaca35d1 (patch)
treeff818e27b869a63df80fbfd0cbb9ac6092bc6c1f
parent739f20b99830bd5d057a5196c8ff8220f78aaa78 (diff)
downloadaur-702fc2299752cb9febac4f5d54e549afdaca35d1.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--simple-irc-client.sh13
3 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95b945277693..3207dbb10dd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = simple-irc-client-bin
pkgdesc = Desktop clients for Simple Irc Client
pkgver = 0.1.1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/Simple-Irc-Client/desktop
arch = x86_64
license = AGPL3
depends = electron25
+ depends = nodejs
provides = simple-irc-client=0.1.1
conflicts = simple-irc-client
source = simple-irc-client-0.1.1.deb::https://github.com/Simple-Irc-Client/desktop/releases/download/v0.1.1/simple-irc-client_0.1.1_amd64.deb
source = simple-irc-client.sh
sha256sums = 8e6a71e380c73061185c8e0c206999a733df3b4be4a4c8c01a9e444c050eb6fc
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = simple-irc-client-bin
diff --git a/PKGBUILD b/PKGBUILD
index 62bbb76d3076..86c408477288 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=simple-irc-client-bin
pkgver=0.1.1
_electronversion=25
-pkgrel=5
+pkgrel=6
pkgdesc="Desktop clients for Simple Irc Client"
arch=('x86_64')
url="https://github.com/Simple-Irc-Client/desktop"
@@ -11,20 +11,20 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
+ 'nodejs'
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
"${pkgname%-bin}.sh"
)
sha256sums=('8e6a71e380c73061185c8e0c206999a733df3b4be4a4c8c01a9e444c050eb6fc'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.zst"
- sed "s| %U||g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/simple-irc-client.sh b/simple-irc-client.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/simple-irc-client.sh
+++ b/simple-irc-client.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file