summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreveryx2023-12-06 21:38:20 +0800
committereveryx2023-12-06 21:58:34 +0800
commitbedf6dbe21268cae3eb9a29d6911413053eae01f (patch)
treeeef2ab3d873db5972dc4f1e755828824e32d2144
downloadaur-bedf6dbe21268cae3eb9a29d6911413053eae01f.tar.gz
upgpkg: 1.4.5.10405
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11e7f355d126
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = simple-live-app-bin
+ pkgdesc = 简简单单的看直播
+ pkgver = 1.4.5.10405
+ pkgrel = 1
+ url = https://github.com/xiaoyaocz/dart_simple_live
+ arch = x86_64
+ license = GPL3
+ depends = libmpv.so
+ source_x86_64 = simple-live-app-bin-1.4.5.10405.deb::https://github.com/xiaoyaocz/dart_simple_live/releases/download/v1.4.5/simple_live_app-1.4.5+10405-linux.deb
+ sha256sums_x86_64 = c73aa5ce6778f62ad3a9c26b80419038c7dedc70db8cdf7e51f98e3b54e41151
+
+pkgname = simple-live-app-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4367ae4a50ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86c90e9d4329
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: everyx <lunt.luo#gmail.com>
+pkgname=simple-live-app-bin
+_build_id=10405
+_version=1.4.5
+pkgver=${_version}.${_build_id}
+pkgrel=1
+
+pkgdesc='简简单单的看直播'
+arch=('x86_64')
+url='https://github.com/xiaoyaocz/dart_simple_live'
+license=('GPL3')
+
+# conflicts=("$pkgname-git" "$pkgname-beta")
+
+source_x86_64=("$pkgname-$pkgver.deb::https://github.com/xiaoyaocz/dart_simple_live/releases/download/v${_version}/simple_live_app-${_version}+${_build_id}-linux.deb")
+sha256sums_x86_64=('c73aa5ce6778f62ad3a9c26b80419038c7dedc70db8cdf7e51f98e3b54e41151')
+depends=('libmpv.so')
+
+package() {
+ bsdtar -xf "$srcdir/data.tar.zst" -C "$pkgdir/"
+
+ install -d "${pkgdir}/usr/bin"
+ ln -s /usr/share/simple_live_app/simple_live_app "${pkgdir}/usr/bin/"
+
+ install -d "${pkgdir}/usr/lib"
+ ln -s /usr/lib/libmpv.so.2.1.0 "${pkgdir}/usr/lib/libmpv.so.1"
+}