summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBadWolfie2015-06-08 13:17:19 -0500
committerBadWolfie2015-06-08 13:17:19 -0500
commit7481dc3ee44ad2ab0fcf7a4cda746776c2aa91dc (patch)
tree4de72976e5116a1875037266e515a06743c2b6dc
downloadaur-7481dc3ee44ad2ab0fcf7a4cda746776c2aa91dc.tar.gz
Migrating to AUR 4, initial commit.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
-rw-r--r--simple-text.install30
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9dbb64105bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = simple-text
+ pkgdesc = A not so simple text and code editor written in Vala (Still in development)
+ pkgver = 0.9.8
+ pkgrel = 5
+ url = https://github.com/BadWolfie
+ install = simple-text.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = vala
+ makedepends = git
+ makedepends = intltool
+ depends = gtk3
+ depends = gtksourceview3
+ depends = libgee
+ depends = vte3
+ depends = libcap
+ depends = dconf
+ options = !emptydirs
+ source = simple-text-0.9.8::git+https://github.com/BadWolfie/simple-text.git
+ md5sums = SKIP
+
+pkgname = simple-text
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d83212302e79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id$
+# Maintainer: Ian Hernandez <ihernandezs@openmailbox.org>
+
+pkgname=simple-text
+pkgver=0.9.8
+pkgrel=5
+pkgdesc="A not so simple text and code editor written in Vala (Still in development)"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="https://github.com/BadWolfie"
+depends=('gtk3' 'gtksourceview3' 'libgee' 'vte3' 'libcap' 'dconf')
+makedepends=('vala' 'git' 'intltool')
+options=('!emptydirs')
+source=("$pkgname-$pkgver::git+$url/$pkgname.git")
+md5sums=('SKIP')
+install=$pkgname.install
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --disable-schemas-compile --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/simple-text.install b/simple-text.install
new file mode 100644
index 000000000000..e7b4e1eb214f
--- /dev/null
+++ b/simple-text.install
@@ -0,0 +1,30 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+}
+
+post_install() {
+ _update
+ usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+} \ No newline at end of file