summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMidAutumnMoon2021-07-11 18:57:49 +0800
committerMidAutumnMoon2021-07-11 18:57:49 +0800
commit9cf21334c7a7e56f9919ec87b62130754be51a81 (patch)
treea6c7446b1b22fdb004cfa776b41f255501724c37
downloadaur-9cf21334c7a7e56f9919ec87b62130754be51a81.tar.gz
Package for simple-torrent
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--simple-torrent.env5
-rw-r--r--simple-torrent.install8
-rw-r--r--simple-torrent.service21
-rw-r--r--simple-torrent.sysusers1
-rw-r--r--simple-torrent.tmpfiles2
7 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be533e00befc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = simple-torrent-bin
+ pkgdesc = Simple Torrent: a self-hosted remote torrent client (rebranded from Cloud Torrent)
+ pkgver = 1.2.23
+ pkgrel = 1
+ url = https://github.com/boypt/simple-torrent
+ install = simple-torrent.install
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ backup = etc/simple-torrent.conf
+ source = simple-torrent.gz::https://github.com/boypt/simple-torrent/releases/download/1.2.23/cloud-torrent_linux_amd64_static.gz
+ source = simple-torrent.sysusers
+ source = simple-torrent.tmpfiles
+ source = simple-torrent.service
+ source = simple-torrent.env
+ sha256sums = 4df4987bf027d6f72b8e54062eda35b34c9af15ea73cbde0c4940aa843a7e280
+ sha256sums = e2660e2d20550154bab3b4bbc3bc857516a059346f8217773b6cb00d12511eb4
+ sha256sums = e1a6099ca9693e2004d3a67ab875c771ec1101f8539f44246f935e663492bd33
+ sha256sums = 8ae649da3a4622be3bbd4f413c2cea3bea5c492efadb3682ee55e2265193924a
+ sha256sums = 7132ed3c257b2c912fe7e707eb60f9dc6f34435ef7521ce33a4a192addeafc3d
+
+pkgname = simple-torrent-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a8848aaf161
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: MidAutumnMoon <mid.autumn0moon@gmail.com>
+
+pkgname=simple-torrent-bin
+_pkgname=simple-torrent
+pkgdesc="Simple Torrent: a self-hosted remote torrent client (rebranded from Cloud Torrent)"
+pkgver=1.2.23
+pkgrel=1
+arch=( 'x86_64' 'aarch64' )
+url='https://github.com/boypt/simple-torrent'
+license=( 'GPL3' )
+
+source=(
+ simple-torrent.gz::https://github.com/boypt/simple-torrent/releases/download/${pkgver}/cloud-torrent_linux_amd64_static.gz
+ simple-torrent.sysusers
+ simple-torrent.tmpfiles
+ simple-torrent.service
+ simple-torrent.env
+)
+
+install="simple-torrent.install"
+backup=( 'etc/simple-torrent.conf' )
+
+sha256sums=(
+ '4df4987bf027d6f72b8e54062eda35b34c9af15ea73cbde0c4940aa843a7e280'
+ 'e2660e2d20550154bab3b4bbc3bc857516a059346f8217773b6cb00d12511eb4'
+ 'e1a6099ca9693e2004d3a67ab875c771ec1101f8539f44246f935e663492bd33'
+ '8ae649da3a4622be3bbd4f413c2cea3bea5c492efadb3682ee55e2265193924a'
+ '7132ed3c257b2c912fe7e707eb60f9dc6f34435ef7521ce33a4a192addeafc3d'
+)
+
+prepare() {
+ gunzip -c ${_pkgname}.gz > ${_pkgname}
+}
+
+package() {
+ install -Dm644 "${srcdir}/${_pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${_pkgname}.conf"
+ install -Dm644 "${srcdir}/${_pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${_pkgname}.conf"
+ install -Dm644 "${srcdir}/${_pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
+ install -Dm644 "${srcdir}/${_pkgname}.env" "${pkgdir}/etc/${_pkgname}.conf"
+
+ install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/simple-torrent"
+}
diff --git a/simple-torrent.env b/simple-torrent.env
new file mode 100644
index 000000000000..d4b12e80fb0f
--- /dev/null
+++ b/simple-torrent.env
@@ -0,0 +1,5 @@
+AUTH=<username>:<password>
+PORT=3000
+
+OPTIONS="--host 127.0.0.1 --disable-log-time -c ./simple-torrent.yaml"
+
diff --git a/simple-torrent.install b/simple-torrent.install
new file mode 100644
index 000000000000..58ee2a4f908e
--- /dev/null
+++ b/simple-torrent.install
@@ -0,0 +1,8 @@
+post_install() {
+ sed -i 's/<username>/simple-torrent/g' '/etc/simple-torrent.conf'
+
+ PASSWD=$(tr -dc A-Za-z0-9 </dev/urandom | head -c 20)
+ sed -i "s/<password>/${PASSWD}/g" '/etc/simple-torrent.conf'
+
+ printf $(tput bold)"The auto-generated default password had been written to /etc/simple-torrent.conf"$(tput sgr0)"\n"
+}
diff --git a/simple-torrent.service b/simple-torrent.service
new file mode 100644
index 000000000000..20611487fe20
--- /dev/null
+++ b/simple-torrent.service
@@ -0,0 +1,21 @@
+[Unit]
+Description = simple-torrent service
+After = network.target
+
+[Service]
+Type = simple
+User = simple-torrent
+Group = simple-torrent
+
+Restart = always
+RestartSec = 5
+RestartPreventExitStatus = 42
+
+EnvironmentFile = /etc/simple-torrent.conf
+WorkingDirectory = /data/torrent
+ExecStart = /usr/bin/simple-torrent $OPTIONS
+
+LimitNOFILE = 50000
+
+[Install]
+WantedBy = multi-user.target
diff --git a/simple-torrent.sysusers b/simple-torrent.sysusers
new file mode 100644
index 000000000000..85e764c52ab2
--- /dev/null
+++ b/simple-torrent.sysusers
@@ -0,0 +1 @@
+u simple-torrent - "simple-torrent user account" /data/torrent
diff --git a/simple-torrent.tmpfiles b/simple-torrent.tmpfiles
new file mode 100644
index 000000000000..3a183c983038
--- /dev/null
+++ b/simple-torrent.tmpfiles
@@ -0,0 +1,2 @@
+d /data/torrent 0755 simple-torrent simple-torrent
+Z /data/torrent - simple-torrent simple-torrent