summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-09-07 16:44:01 -0300
committerDaniel Bermond2023-09-07 16:44:01 -0300
commita39a361b4ed218940f0b4f96147528431cccfb68 (patch)
treee12d159b0643f46b9b1f8666e353ff323b986948
parentfbd10a499da938d292cd0e1594e6d69f13a940ec (diff)
downloadaur-a39a361b4ed218940f0b4f96147528431cccfb68.tar.gz
Update to version 2023.09.2
-rw-r--r--.SRCINFO6
-rw-r--r--020-simple64-fix-paths.patch6
-rw-r--r--PKGBUILD4
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e1d2b1966d5..82a07bd8caa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = simple64
pkgdesc = Nintendo64 emulator based on Mupen64Plus
- pkgver = 2023.09.1
+ pkgver = 2023.09.2
pkgrel = 1
url = https://simple64.github.io/
arch = x86_64
@@ -28,7 +28,7 @@ pkgbase = simple64
conflicts = m64p
conflicts = mupen64plus
replaces = m64p
- source = git+https://github.com/simple64/simple64.git#tag=v2023.09.1
+ source = git+https://github.com/simple64/simple64.git#tag=v2023.09.2
source = simple64-cheat-parser::git+https://github.com/simple64/cheat-parser.git#commit=9ae289c157030486f0b924f4b7080a375c2d684e
source = 010-simple64-remove-bundled-discord-and-vosk.patch
source = 020-simple64-fix-paths.patch
@@ -36,7 +36,7 @@ pkgbase = simple64
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 070f86d9fdfcd4efa7195817bf61f6688b85c34a56a4f2f8dc6dc2c6a7a8f00f
- sha256sums = 3f64f225a245a8648fb7a790bf2fce232cd37e7220238d6829abab9c745a1c40
+ sha256sums = 8bab53ec62f144cc9c93fa7a30c7ac37e410ce562c72ade6afa9ba1afe406694
sha256sums = acd624abe80b3399ef76c9f6ff45c5194ade6640a0fb18e43fd646c60345a883
pkgname = simple64
diff --git a/020-simple64-fix-paths.patch b/020-simple64-fix-paths.patch
index 2cf9a36b5e91..9d407a981d09 100644
--- a/020-simple64-fix-paths.patch
+++ b/020-simple64-fix-paths.patch
@@ -1,6 +1,6 @@
--- a/simple64-gui/cheats.cpp
+++ b/simple64-gui/cheats.cpp
-@@ -192,7 +192,7 @@ QString getCheatGameName()
+@@ -229,7 +229,7 @@ QString getCheatGameName()
QJsonObject loadCheatData(QString gameName)
{
@@ -29,7 +29,7 @@
memset(&discord_app, 0, sizeof(discord_app));
-@@ -919,7 +919,7 @@ void MainWindow::loadCoreLib()
+@@ -929,7 +929,7 @@ void MainWindow::loadCoreLib()
#ifdef CORE_LIBRARY_PATH
QString corePath = CORE_LIBRARY_PATH;
#else
@@ -38,7 +38,7 @@
#endif
m64p_error res = osal_dynlib_open(&coreLib, QDir(corePath).filePath(OSAL_DEFAULT_DYNLIB_FILENAME).toUtf8().constData());
-@@ -1012,7 +1012,7 @@ void MainWindow::loadPlugins()
+@@ -1022,7 +1022,7 @@ void MainWindow::loadPlugins()
#ifdef PLUGIN_DIR_PATH
QString pluginPath = PLUGIN_DIR_PATH;
#else
diff --git a/PKGBUILD b/PKGBUILD
index a02206c0574f..2dcc56a4125e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=simple64
-pkgver=2023.09.1
+pkgver=2023.09.2
pkgrel=1
_cheat_parser_commit='9ae289c157030486f0b924f4b7080a375c2d684e'
pkgdesc='Nintendo64 emulator based on Mupen64Plus'
@@ -25,7 +25,7 @@ source=("git+https://github.com/simple64/simple64.git#tag=v${pkgver}"
sha256sums=('SKIP'
'SKIP'
'070f86d9fdfcd4efa7195817bf61f6688b85c34a56a4f2f8dc6dc2c6a7a8f00f'
- '3f64f225a245a8648fb7a790bf2fce232cd37e7220238d6829abab9c745a1c40'
+ '8bab53ec62f144cc9c93fa7a30c7ac37e410ce562c72ade6afa9ba1afe406694'
'acd624abe80b3399ef76c9f6ff45c5194ade6640a0fb18e43fd646c60345a883')
prepare() {