summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorejno2015-06-13 12:05:40 -0400
committerejno2015-06-13 12:05:40 -0400
commit8b62ef19f45afc9c53cd2352bfcb0042fc95db06 (patch)
tree2af4bc62cd9779f55d22d6340320a5855fe2a434
downloadaur-8b62ef19f45afc9c53cd2352bfcb0042fc95db06.tar.gz
initial import to aur4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08db0162de77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = simplecv
+ pkgdesc = Framework for computer (machine) vision in Python, providing a unified, Pythonic interface to image aquisition, conversion, manipulation, and feature extraction.
+ pkgver = 1.3
+ pkgrel = 2
+ url = http://simplecv.org/
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = opencv
+ depends = python2-pillow
+ depends = python2-pygame
+ depends = python2-scipy
+ optdepends = ipython2: for using SimpleCV with the IPython Notebook
+ conflicts = simplecv-git
+ source = http://downloads.sourceforge.net/project/simplecv/1.3/SimpleCV-1.3.tar.gz
+ sha256sums = 7a0aaf61f357a78429ff4409f75d4ac67b9924f06013245706a3ccfcff8c92b0
+
+pkgname = simplecv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4af473a8b342
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=simplecv
+pkgver=1.3
+pkgrel=2
+pkgdesc='Framework for computer (machine) vision in Python, providing a unified, Pythonic interface to image aquisition, conversion, manipulation, and feature extraction.'
+url='http://simplecv.org/'
+license=('BSD')
+arch=('any')
+depends=('opencv' 'python2-pillow' 'python2-pygame' 'python2-scipy')
+makedepends=('python2-setuptools')
+optdepends=('ipython2: for using SimpleCV with the IPython Notebook')
+conflicts=('simplecv-git')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgver}/SimpleCV-${pkgver}.tar.gz")
+sha256sums=('7a0aaf61f357a78429ff4409f75d4ac67b9924f06013245706a3ccfcff8c92b0')
+
+
+build() {
+ cd SimpleCV
+ python2 setup.py build
+}
+
+
+package() {
+ cd SimpleCV
+ python2 setup.py install "--root=${pkgdir}" --optimize=1
+ install -D --mode=u=rw,go=r LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}