summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-08-04 01:47:49 +0800
committerYen Chi Hsuan2017-08-04 01:47:49 +0800
commit0aedb91bc210ad37526cee04e838354985d0fa66 (patch)
tree3036a5fd676d3292ffa1a213eada411a71fc3b4c
parent6fae745d93e1168ac052f91f6fd41fd9372ae567 (diff)
downloadaur-0aedb91bc210ad37526cee04e838354985d0fa66.tar.gz
Bump to 1.0.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--Rlib.patch26
-rw-r--r--lua51.patch26
4 files changed, 15 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37605a037ce5..28fef39f6e93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = simpleitk
pkgdesc = A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages.
- pkgver = 1.0.0
- pkgrel = 5
+ pkgver = 1.0.1
+ pkgrel = 1
url = http://www.simpleitk.org/
arch = i686
arch = x86_64
@@ -32,12 +32,10 @@ pkgbase = simpleitk
optdepends = ruby: Ruby bindings
optdepends = tcl: Tcl/TK bindings
optdepends = tk: Tcl/TK bindings
- source = git+https://github.com/SimpleITK/SimpleITK#tag=v1.0.0
- source = Rlib.patch
+ source = git+https://github.com/SimpleITK/SimpleITK#tag=v1.0.1
source = lua51.patch
md5sums = SKIP
- md5sums = 2888336abcbb122a49cb5817ac98f36c
- md5sums = a25fe3562664dbef433a3f2cc20d6c39
+ md5sums = 284e72ada1848a2b99b3c9b8a6916979
pkgname = simpleitk
diff --git a/PKGBUILD b/PKGBUILD
index 8d0f73343c42..0ea3d6789f78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Yen Chi Hsuan <yan12125 at gmail.com>
_pkgname=SimpleITK
pkgname=simpleitk
-pkgver=1.0.0
-_pypkgver=1.0.0
-pkgrel=5
+pkgver=1.0.1
+_pypkgver=1.0.1
+pkgrel=1
pkgdesc="A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages."
arch=('i686' 'x86_64')
url="http://www.simpleitk.org/"
@@ -31,19 +31,16 @@ optdepends=(
)
source=(
"git+https://github.com/$_pkgname/$_pkgname#tag=v$pkgver"
- 'Rlib.patch'
'lua51.patch'
)
md5sums=('SKIP'
- '2888336abcbb122a49cb5817ac98f36c'
- 'a25fe3562664dbef433a3f2cc20d6c39')
+ '284e72ada1848a2b99b3c9b8a6916979')
prepare() {
cd "$_pkgname"
mkdir -p build
- patch -Np1 -i ../Rlib.patch
patch -Np1 -i ../lua51.patch
}
diff --git a/Rlib.patch b/Rlib.patch
deleted file mode 100644
index ea43763821c0..000000000000
--- a/Rlib.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/Wrapping/R/CMakeLists.txt b/Wrapping/R/CMakeLists.txt
-index 87753ad..4740cf2 100644
---- a/Wrapping/R/CMakeLists.txt
-+++ b/Wrapping/R/CMakeLists.txt
-@@ -91,6 +91,6 @@ add_custom_command( TARGET ${SWIG_MODULE_SimpleITK_TARGET_NAME}
- COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_CURRENT_BINARY_DIR}/R_libs
- COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_BINARY_DIR}/SimpleITK.R ${CMAKE_CURRENT_BINARY_DIR}/Packaging/SimpleITK/R/
- # install for running tests and create binary package
-- COMMAND ${R_COMMAND} CMD INSTALL --build ${CMAKE_CURRENT_BINARY_DIR}/Packaging/SimpleITK --library=${CMAKE_CURRENT_BINARY_DIR}/R_libs
-+ COMMAND ${CMAKE_COMMAND} -E env "LD_LIBRARY_PATH=${CMAKE_BINARY_DIR}/lib" ${R_COMMAND} CMD INSTALL --build ${CMAKE_CURRENT_BINARY_DIR}/Packaging/SimpleITK --library=${CMAKE_CURRENT_BINARY_DIR}/R_libs
- COMMENT "Installing R package for testing and building binary version for distribution"
- )
-diff --git a/Wrapping/R/SimpleITK.i b/Wrapping/R/SimpleITK.i
-index b6688db..e034959 100644
---- a/Wrapping/R/SimpleITK.i
-+++ b/Wrapping/R/SimpleITK.i
-@@ -1,3 +1,9 @@
-+%begin %{
-+#define NO_C_HEADERS
-+#include <cstdio>
-+#include <cstddef>
-+%}
-+
- %include SimpleITK_Common.i
-
- %include "sitkRCommand.h"
diff --git a/lua51.patch b/lua51.patch
index 8f32df4615e8..a198e72ddbcf 100644
--- a/lua51.patch
+++ b/lua51.patch
@@ -11,38 +11,26 @@
if(LUA_EXECUTABLE)
--- a/Wrapping/Lua/CMakeLists.txt 2016-07-15 02:21:14.748778896 +0800
+++ Wrapping/Lua/CMakeLists.txt.orig 2016-07-15 02:20:55.322111581 +0800
-@@ -5,14 +5,7 @@
+@@ -5,7 +5,7 @@
include(../../CMake/sitkProjectLanguageCommon.cmake)
--if (CMAKE_VERSION VERSION_LESS "3")
-- find_package ( Lua51 ${_QUIET} )
-- if ( NOT LUA_FOUND )
-- find_package ( Lua50 ${_QUIET} )
-- endif()
--else()
-- find_package ( Lua ${_QUIET} )
--endif()
-+find_package ( Lua51 ${_QUIET} )
+-find_package ( Lua REQUIRED )
++find_package ( Lua51 REQUIRED )
set( LUA_ADDITIONAL_LIBRARIES "" CACHE STRING "Additional libraries which may be needed for lua executable such as readline.")
mark_as_advanced( LUA_ADDITIONAL_LIBRARIES )
--- a/CMake/sitkLanguageOptions.cmake 2016-07-15 17:56:50.830654990 +0800
+++ b/CMake/sitkLanguageOptions.cmake 2016-07-15 17:57:23.547322749 +0800
-@@ -31,15 +31,8 @@
+@@ -31,9 +31,9 @@
# Setup the option for each language
#
set_QUIET( WRAP_LUA )
--if (CMAKE_VERSION VERSION_LESS "3")
-- find_package ( Lua51 ${_QUIET} )
-- if ( NOT LUA_FOUND )
-- find_package ( Lua50 ${_QUIET} )
-- endif()
--else()
-- find_package ( Lua ${_QUIET} )
--endif()
+-find_package ( Lua ${_QUIET} )
+-
-if ( LUA_FOUND )
+find_package ( Lua51 ${_QUIET} )
++
+if ( LUA51_FOUND )
set( WRAP_LUA_DEFAULT ${WRAP_DEFAULT} )
else()