summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-07-27 18:51:06 +0800
committerYen Chi Hsuan2016-07-27 18:51:06 +0800
commit0af2168690cbaebe6d2d4f314d11315940f5dbe3 (patch)
treebccec5fdd61120760ae82aca7fff23a076b735fc
parent9ec8ddae2559cbd61e4ce43624577ade97ab0a8e (diff)
downloadaur-0af2168690cbaebe6d2d4f314d11315940f5dbe3.tar.gz
Bump to 0.10rc2
Drop unnecessary lua patches
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--lua51.patch19
3 files changed, 10 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd485b7e631b..0d585957f7d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jul 16 08:00:54 UTC 2016
+# Wed Jul 27 10:50:52 UTC 2016
pkgbase = simpleitk
pkgdesc = A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages.
- pkgver = 0.10rc1
- pkgrel = 3
+ pkgver = 0.10rc2
+ pkgrel = 1
url = http://www.simpleitk.org/
arch = i686
arch = x86_64
@@ -32,12 +32,12 @@ pkgbase = simpleitk
optdepends = ruby: Ruby bindings
optdepends = tcl: Tcl/TK bindings
optdepends = tk: Tcl/TK bindings
- source = git+https://github.com/SimpleITK/SimpleITK#tag=v0.10rc1
+ source = git+https://github.com/SimpleITK/SimpleITK#tag=v0.10rc2
source = Rlib.patch
source = lua51.patch
md5sums = SKIP
md5sums = 2888336abcbb122a49cb5817ac98f36c
- md5sums = 89cd23ce562229b3b2b6301aee18fced
+ md5sums = 9cde58e7639dadbca34e501234619ef3
pkgname = simpleitk
diff --git a/PKGBUILD b/PKGBUILD
index 05b7b5db4f87..309fa870289e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Yen Chi Hsuan <yan12125 at gmail.com>
_pkgname=SimpleITK
pkgname=simpleitk
-pkgver=0.10rc1
-_pypkgver=0.10.0rc1
-pkgrel=3
+pkgver=0.10rc2
+_pypkgver=0.10.0rc2
+pkgrel=1
pkgdesc="A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages."
arch=('i686' 'x86_64')
url="http://www.simpleitk.org/"
@@ -27,7 +27,7 @@ source=(
)
md5sums=('SKIP'
'2888336abcbb122a49cb5817ac98f36c'
- '89cd23ce562229b3b2b6301aee18fced')
+ '9cde58e7639dadbca34e501234619ef3')
prepare() {
cd "$_pkgname"
@@ -57,7 +57,7 @@ build() {
-DWRAP_JAVA:BOOL=OFF \
..
- make all dist
+ make all PythonVirtualEnv dist
}
package() {
diff --git a/lua51.patch b/lua51.patch
index 1c3a7e13beb6..13618d7e9631 100644
--- a/lua51.patch
+++ b/lua51.patch
@@ -27,25 +27,6 @@
set( LUA_ADDITIONAL_LIBRARIES "" CACHE STRING "Additional libraries which may be needed for lua executable such as readline.")
mark_as_advanced( LUA_ADDITIONAL_LIBRARIES )
---- a/CMake/sitkGenerateFilterSource.cmake 2016-07-15 04:16:21.529009726 +0800
-+++ b/CMake/sitkGenerateFilterSource.cmake 2016-07-15 04:16:41.519010392 +0800
-@@ -2,16 +2,8 @@
- # Find a Lua executable
- #
- if ( NOT SITK_LUA_EXECUTABLE )
-- set ( SAVE_LUA_EXECUTABLE ${LUA_EXECUTABLE} )
--
- find_package( LuaInterp REQUIRED 5.1 )
- set( SITK_LUA_EXECUTABLE ${LUA_EXECUTABLE} CACHE PATH "Lua executable used for code generation." )
--
-- if (DEFINED SAVE_LUA_EXECUTABLE)
-- set( LUA_EXECUTABLE ${SAVE_LUA_EXECUTABLE} CACHE )
-- else()
-- unset( LUA_EXECUTABLE CACHE )
-- endif()
- endif()
-
- # Get the Lua version
--- a/CMake/sitkLanguageOptions.cmake 2016-07-15 17:56:50.830654990 +0800
+++ b/CMake/sitkLanguageOptions.cmake 2016-07-15 17:57:23.547322749 +0800
@@ -31,15 +31,8 @@