summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-03-31 01:46:54 +0800
committerYen Chi Hsuan2017-03-31 01:46:54 +0800
commit35f98a851b48c8928c3bfd2e0819921ecb4093f8 (patch)
treee0b1407586c4b05edcb8c8b4e4754670983a6313
parent4c6645734703d538542635343ed2e4147808d5a5 (diff)
downloadaur-35f98a851b48c8928c3bfd2e0819921ecb4093f8.tar.gz
Drop clang dep as it can be built with g++ now
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 3 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19574f6961c9..61f667867e2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = simpleitk
pkgdesc = A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages.
pkgver = 1.0rc3
- pkgrel = 1
+ pkgrel = 2
url = http://www.simpleitk.org/
arch = i686
arch = x86_64
license = Apache
makedepends = cmake
- makedepends = clang
makedepends = git
makedepends = lua51
makedepends = mono
diff --git a/PKGBUILD b/PKGBUILD
index a28d26fd979a..d20cf1832980 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@ _pkgname=SimpleITK
pkgname=simpleitk
pkgver=1.0rc3
_pypkgver=1.0.0rc3
-pkgrel=1
+pkgrel=2
pkgdesc="A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages."
arch=('i686' 'x86_64')
url="http://www.simpleitk.org/"
license=('Apache')
depends=('gcc-libs' 'insight-toolkit>=4.11.0')
-makedepends=('cmake' 'clang' 'git' 'lua51' 'mono' 'python' 'python-pip' 'python-virtualenv' 'python-numpy' 'r' 'ruby' 'swig' 'tcl' 'tk')
+makedepends=('cmake' 'git' 'lua51' 'mono' 'python' 'python-pip' 'python-virtualenv' 'python-numpy' 'r' 'ruby' 'swig' 'tcl' 'tk')
optdepends=(
'lua51: Lua bindings'
'mono: C# bindings'
@@ -41,11 +41,6 @@ prepare() {
build() {
cd "$_pkgname/build"
- export CC=clang
- export CXX=clang++
- export CXXFLAGS="-std=c++11 $CXXFLAGS"
- export CPP="clang -E"
-
# TODO: Java binding is broken with swig 3.0.9 and openjdk8
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -65,11 +60,6 @@ package() {
cd $_builddir
- export CC=clang
- export CXX=clang++
- export CXXFLAGS="-std=c++11 $CXXFLAGS"
- export CPP="clang -E"
-
make DESTDIR="$pkgdir/" install
pip install --root="$pkgdir/" --ignore-installed \