summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-03-27 10:03:54 +0200
committerMartino Pilia2018-03-27 10:03:54 +0200
commit5f329b269d2326ec0da91d1a287dd1938499ae73 (patch)
tree88c57592985905195cd935662ab9c064a3877cb9
parent0bd99238384695d2e59ba124df51944c1f792452 (diff)
downloadaur-5f329b269d2326ec0da91d1a287dd1938499ae73.tar.gz
fix missing dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
-rw-r--r--lua51.patch37
3 files changed, 4 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d366c58c5e9..a58b218bf495 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = simpleitk
pkgdesc = A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages.
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.simpleitk.org/
arch = i686
arch = x86_64
license = Apache
+ makedepends = clang
makedepends = cmake
makedepends = git
makedepends = swig
diff --git a/PKGBUILD b/PKGBUILD
index 862aa019029d..0e3188c7848a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_pkgname=SimpleITK
pkgname=simpleitk
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages."
arch=('i686' 'x86_64')
url="http://www.simpleitk.org/"
license=('Apache')
depends=('gcc-libs' 'insight-toolkit>=4.13')
makedepends=(
- 'cmake' 'git' 'swig'
+ 'clang' 'cmake' 'git' 'swig'
'java-environment'
'lua51'
'mono'
@@ -44,7 +44,6 @@ build() {
_lua51_version=$(pacman -Qi lua51 | grep '^Version' | egrep -o '[0-9]\.[0-9]\.[0-9]')
CC=clang CXX=clang++ \
- CXXFLAGS= \
JAVA_HOME=$_java_home \
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
diff --git a/lua51.patch b/lua51.patch
deleted file mode 100644
index a198e72ddbcf..000000000000
--- a/lua51.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/CMake/FindLuaInterp.cmake 2016-07-15 02:29:39.418795763 +0800
-+++ b/CMake/FindLuaInterp.cmake 2016-07-15 02:29:45.812129311 +0800
-@@ -11,7 +11,7 @@
- # LUA_EXECUTABLE_VERSION_STRING - version of lua found
-
- find_program(LUA_EXECUTABLE
-- NAMES lua
-+ NAMES lua5.1 lua
- )
-
- if(LUA_EXECUTABLE)
---- a/Wrapping/Lua/CMakeLists.txt 2016-07-15 02:21:14.748778896 +0800
-+++ Wrapping/Lua/CMakeLists.txt.orig 2016-07-15 02:20:55.322111581 +0800
-@@ -5,7 +5,7 @@
- include(../../CMake/sitkProjectLanguageCommon.cmake)
-
-
--find_package ( Lua REQUIRED )
-+find_package ( Lua51 REQUIRED )
-
- set( LUA_ADDITIONAL_LIBRARIES "" CACHE STRING "Additional libraries which may be needed for lua executable such as readline.")
- mark_as_advanced( LUA_ADDITIONAL_LIBRARIES )
---- a/CMake/sitkLanguageOptions.cmake 2016-07-15 17:56:50.830654990 +0800
-+++ b/CMake/sitkLanguageOptions.cmake 2016-07-15 17:57:23.547322749 +0800
-@@ -31,9 +31,9 @@
- # Setup the option for each language
- #
- set_QUIET( WRAP_LUA )
--find_package ( Lua ${_QUIET} )
--
--if ( LUA_FOUND )
-+find_package ( Lua51 ${_QUIET} )
-+
-+if ( LUA51_FOUND )
- set( WRAP_LUA_DEFAULT ${WRAP_DEFAULT} )
- else()
- set( WRAP_LUA_DEFAULT OFF )