summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-02-16 17:48:42 +0800
committerYen Chi Hsuan2017-02-16 17:48:42 +0800
commit986a54a668100570c22e63e5af97d66b34be8347 (patch)
treee47109c762616e9c3f9a39b80be73db42c964f4a
parent38165b72b46f9bc933470824bb1b48058cbd9907 (diff)
downloadaur-986a54a668100570c22e63e5af97d66b34be8347.tar.gz
Bump to 1.0rc1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--lua51.patch2
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 533b04ada616..954b7e263637 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Jul 29 16:25:06 UTC 2016
pkgbase = simpleitk
pkgdesc = A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages.
- pkgver = 0.10.0
+ pkgver = 1.0rc1
pkgrel = 1
url = http://www.simpleitk.org/
arch = i686
@@ -23,7 +21,7 @@ pkgbase = simpleitk
makedepends = tcl
makedepends = tk
depends = gcc-libs
- depends = insight-toolkit
+ depends = insight-toolkit>=4.11.0
optdepends = lua51: Lua bindings
optdepends = mono: C# bindings
optdepends = python: Python bindings
@@ -32,12 +30,12 @@ pkgbase = simpleitk
optdepends = ruby: Ruby bindings
optdepends = tcl: Tcl/TK bindings
optdepends = tk: Tcl/TK bindings
- source = git+https://github.com/SimpleITK/SimpleITK#tag=v0.10.0
+ source = git+https://github.com/SimpleITK/SimpleITK#tag=v1.0rc1
source = Rlib.patch
source = lua51.patch
md5sums = SKIP
md5sums = 2888336abcbb122a49cb5817ac98f36c
- md5sums = 9cde58e7639dadbca34e501234619ef3
+ md5sums = a25fe3562664dbef433a3f2cc20d6c39
pkgname = simpleitk
diff --git a/PKGBUILD b/PKGBUILD
index 9629f9b59153..2e5b385cf639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Yen Chi Hsuan <yan12125 at gmail.com>
_pkgname=SimpleITK
pkgname=simpleitk
-pkgver=0.10.0
+pkgver=1.0rc1
+_pypkgver=1.0.0rc1
pkgrel=1
pkgdesc="A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages."
arch=('i686' 'x86_64')
url="http://www.simpleitk.org/"
license=('Apache')
-depends=('gcc-libs' 'insight-toolkit')
+depends=('gcc-libs' 'insight-toolkit>=4.11.0')
makedepends=('cmake' 'clang' 'git' 'lua51' 'mono' 'python' 'python-pip' 'python-virtualenv' 'python-numpy' 'r' 'ruby' 'swig' 'tcl' 'tk')
optdepends=(
'lua51: Lua bindings'
@@ -26,7 +27,7 @@ source=(
)
md5sums=('SKIP'
'2888336abcbb122a49cb5817ac98f36c'
- '9cde58e7639dadbca34e501234619ef3')
+ 'a25fe3562664dbef433a3f2cc20d6c39')
prepare() {
cd "$_pkgname"
@@ -72,7 +73,7 @@ package() {
make DESTDIR="$pkgdir/" install
pip install --root="$pkgdir/" --ignore-installed \
- "$_builddir/Wrapping/Python/dist/$_pkgname-$pkgver"*"-linux_$CARCH.whl"
+ "$_builddir/Wrapping/Python/dist/$_pkgname-$_pypkgver"*"-linux_$CARCH.whl"
install -d -Dm755 "$pkgdir/usr/lib/lua/5.1/"
install -Dm755 "$_builddir/Wrapping/Lua/lib/$_pkgname.so" "$pkgdir/usr/lib/lua/5.1/$_pkgname.so"
diff --git a/lua51.patch b/lua51.patch
index 13618d7e9631..8f32df4615e8 100644
--- a/lua51.patch
+++ b/lua51.patch
@@ -44,6 +44,6 @@
-if ( LUA_FOUND )
+find_package ( Lua51 ${_QUIET} )
+if ( LUA51_FOUND )
- set( WRAP_LUA_DEFAULT ON )
+ set( WRAP_LUA_DEFAULT ${WRAP_DEFAULT} )
else()
set( WRAP_LUA_DEFAULT OFF )