summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkewl fft2019-02-21 18:44:11 +0000
committerkewl fft2019-02-21 18:44:11 +0000
commit25e5e6df4f005d38bed051098a1dbb4ea4e620dd (patch)
treed3753c38ddf617e5d727719288599b756e425df4
parent2b93aa200b0afed70236adce244252f38e241092 (diff)
downloadaur-25e5e6df4f005d38bed051098a1dbb4ea4e620dd.tar.gz
Update to version 1.5.0-5
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da3968dfd134..e82410bcf755 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = simplenote-electron-bin
pkgdesc = The simplest way to keep notes
- pkgver = 1.4.1
- pkgrel = 1
+ pkgver = 1.5.0
+ pkgrel = 5
url = https://github.com/Automattic/simplenote-electron
arch = x86_64
license = GPL2
- depends = gcc-libs
- depends = gconf
depends = alsa-lib
depends = nss
depends = libxtst
- depends = gtk2
+ depends = gtk3
depends = libxss
provides = simplenote
- source = https://github.com/Automattic/simplenote-electron/releases/download/v1.4.1/Simplenote-linux-1.4.1-amd64.deb
- sha256sums = bfc89c486d63c48123ba49766339ff3d7e3eab64b92149944ee869ebc287a7b9
+ source = https://github.com/Automattic/simplenote-electron/releases/download/v1.5.0/Simplenote-linux-1.5.0-amd64.deb
+ sha256sums = 4e577a0a0cf1a87cc0cf4a115b4d065835469d1262887cf76ee50b20d809d243
pkgname = simplenote-electron-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5a1e4e376cd9..537f8a68c485 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,27 @@
# Maintainer: Kewl <kewl@alto.eu.org>
pkgname=simplenote-electron-bin
-_pkgname=simplenote
-pkgver=1.4.1
-pkgrel=1
+pkgver=1.5.0
+pkgrel=5
pkgdesc="The simplest way to keep notes"
arch=('x86_64')
url="https://github.com/Automattic/simplenote-electron"
license=('GPL2')
-depends=('gcc-libs' 'gconf' 'alsa-lib' 'nss' 'libxtst' 'gtk2' 'libxss')
+depends=('alsa-lib' 'nss' 'libxtst' 'gtk3' 'libxss')
provides=('simplenote')
-source=("https://github.com/Automattic/simplenote-electron/releases/download/v${pkgver}/Simplenote-linux-${pkgver}-amd64.deb")
-
-sha256sums=('bfc89c486d63c48123ba49766339ff3d7e3eab64b92149944ee869ebc287a7b9')
+source=("${url}/releases/download/v${pkgver}/Simplenote-linux-${pkgver}-amd64.deb")
+sha256sums=('4e577a0a0cf1a87cc0cf4a115b4d065835469d1262887cf76ee50b20d809d243')
# Warning: the release deb file has been known to be silently modified,
# resulting in a different checksum. If the checksum fails to validate, this is
-# most likely the cause. If you are concerned about the security implications
-# of this, please do not install this package. The web app at
-# https://app.simplenote.com/ may better suit.
+# most likely the cause. If you are concerned about the security implications of this,
+# do not install this package. The web app at https://app.simplenote.com/ may better suit.
#
-# This issue has been raised with Automattic on github: https://github.com/Automattic/simplenote-electron/issues/759
+# This issue has been raised and acknowledged by Automattic on github: https://github.com/Automattic/simplenote-electron/issues/759
# See also related conversation on the aur: https://aur.archlinux.org/packages/simplenote-electron-bin/
-
package() {
bsdtar -xv -C "${pkgdir}" -f "${srcdir}/data.tar.xz"
mkdir -p ${pkgdir}/usr/bin/
- ln -s /opt/Simplenote/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ ln -s /opt/Simplenote/${pkgname%-electron-bin} ${pkgdir}/usr/bin/${pkgname%-electron-bin}
}