summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkewl fft2020-08-09 09:45:45 -0400
committerkewl fft2020-08-09 09:45:45 -0400
commit452f8fb740fccb71d588b37509d505bb38f2587b (patch)
tree46385fdfe0429178a93a0d86cf8f146e50558e4e
parent984184bee39ad0ce4e3e413f70df44b218aeec5e (diff)
downloadaur-452f8fb740fccb71d588b37509d505bb38f2587b.tar.gz
Update to version 1.20.0-1
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c9196408cc5..c5dd4bbac00f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,18 @@ pkgname=simplenote-electron-bin
pkgver=1.20.0
pkgrel=1
pkgdesc="The simplest way to keep notes"
-arch=('x86_64')
+arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/Automattic/simplenote-electron"
license=('GPL2')
depends=('nss' 'gtk3' 'libxss')
provides=('simplenote')
-source=("${url}/releases/download/v${pkgver}/Simplenote-linux-${pkgver}-amd64.deb")
-sha256sums=('c78a061035b889a837aff29f22131cf367b7a596e49e2beaee7615a69645fb3b')
+source_x86_64=("${url}/releases/download/v${pkgver}/Simplenote-linux-${pkgver}-amd64.deb")
+source_armv7h=("${url}/releases/download/v${pkgver}/Simplenote-linux-${pkgver}-armv7l.deb")
+source_aarch64=("${url}/releases/download/v${pkgver}/Simplenote-linux-${pkgver}-arm64.deb")
+sha256sums_x86_64=('c78a061035b889a837aff29f22131cf367b7a596e49e2beaee7615a69645fb3b')
+sha256sums_armv7h=('899016470eabbdf8dd404f5eefe282fa857debf3475a73a39c7cd7400db3a84c')
+sha256sums_aarch64=('1e69a80a386ea70df0d8084df70da2052c03fead5e49523bfe82aa88bcf476d0')
+
# Warning: the release deb file has been known to be silently modified,
# resulting in a different checksum. If the checksum fails to validate, this is
# most likely the cause. If you are concerned about the security implications of this,
@@ -22,7 +27,6 @@ sha256sums=('c78a061035b889a837aff29f22131cf367b7a596e49e2beaee7615a69645fb3b')
package() {
bsdtar -xv -C "${pkgdir}" -f "${srcdir}/data.tar.xz"
-
mkdir -p "${pkgdir}/usr/bin/"
ln -s "/opt/Simplenote/${pkgname%-electron-bin}" "${pkgdir}/usr/bin"
}