summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten Baert2015-06-20 20:36:10 +0200
committerMaarten Baert2015-06-20 20:36:10 +0200
commita6f642697d69e9dced5e733fe0226173c6e1ea20 (patch)
tree43ba1cd150c9a93fac15249a12116c3f8620ee09
downloadaur-a6f642697d69e9dced5e733fe0226173c6e1ea20.tar.gz
Updated package
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD33
-rw-r--r--simplescreenrecorder-git.install11
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46d71613e644
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+# Generated by makepkg 4.2.0
+# Fri Jan 23 23:20:36 UTC 2015
+pkgbase = simplescreenrecorder-git
+ pkgdesc = A feature-rich screen recorder that supports X11 and OpenGL. (Git version)
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = http://www.maartenbaert.be/simplescreenrecorder/
+ install = simplescreenrecorder-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt4
+ depends = ffmpeg
+ depends = alsa-lib
+ depends = libpulse
+ depends = jack
+ depends = libgl
+ depends = glu
+ depends = libx11
+ depends = libxfixes
+ depends = libxext
+ depends = libxi
+ optdepends = lib32-simplescreenrecorder-git: OpenGL recording of 32-bit applications
+ provides = simplescreenrecorder
+ conflicts = simplescreenrecorder
+ options = !libtool
+ source = git+https://github.com/MaartenBaert/ssr.git
+ md5sums = SKIP
+
+pkgname = simplescreenrecorder-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29c37d52e265
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=simplescreenrecorder-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="A feature-rich screen recorder that supports X11 and OpenGL. (Git version)"
+arch=("i686" "x86_64")
+url="http://www.maartenbaert.be/simplescreenrecorder/"
+license=("GPL3")
+source=("git+https://github.com/MaartenBaert/ssr.git")
+md5sums=("SKIP")
+depends=("qt4" "ffmpeg" "alsa-lib" "libpulse" "jack" "libgl" "glu" "libx11" "libxfixes" "libxext" "libxi")
+if test "$CARCH" == x86_64; then
+ optdepends=("lib32-simplescreenrecorder-git: OpenGL recording of 32-bit applications")
+fi
+makedepends=("git")
+conflicts=("simplescreenrecorder")
+provides=("simplescreenrecorder")
+options=("!libtool")
+install=simplescreenrecorder-git.install
+
+pkgver() {
+ cd "${srcdir}/ssr"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+build() {
+ cd "${srcdir}/ssr"
+ ./configure --prefix=/usr --disable-assert
+ make
+}
+package() {
+ cd "${srcdir}/ssr"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/simplescreenrecorder-git.install b/simplescreenrecorder-git.install
new file mode 100644
index 000000000000..5fc896fdc761
--- /dev/null
+++ b/simplescreenrecorder-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -f usr/share/icons/hicolor
+ ldconfig
+}
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ post_install
+}