summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Krenek (Mikos)2017-03-17 14:00:30 +0100
committerMichal Krenek (Mikos)2017-03-17 14:00:30 +0100
commit74da0d526b6709daab8a9ca0887c7328bf19e18d (patch)
tree8946e83cf4ca980e6a894f2bb41e9458e16fd8bb
downloadaur-74da0d526b6709daab8a9ca0887c7328bf19e18d.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cc547264bf8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Mar 17 13:00:06 UTC 2017
+pkgbase = simplespectral
+ pkgdesc = Heavily simplified scipy.signal.spectral module which only depends on NumPy and supports pyFFTW
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/xmikos/simplespectral
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ optdepends = python-pyfftw: fastest FFT calculations with FFTW library
+ optdepends = python-scipy: faster FFT calculations with scipy.fftpack library
+ source = https://github.com/xmikos/simplespectral/archive/v1.0.0.tar.gz
+ sha256sums = 4342741f7054c71f7c5fb9d38df49e048e0a4e20eb53cefd247e47937644cad0
+
+pkgname = simplespectral
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4397e63ee6bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
+pkgname=simplespectral
+_pkgname=simplespectral
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Heavily simplified scipy.signal.spectral module which only depends on NumPy and supports pyFFTW"
+arch=('any')
+url="https://github.com/xmikos/simplespectral"
+license=('MIT')
+depends=('python' 'python-numpy')
+makedepends=('python-setuptools')
+optdepends=(
+ 'python-pyfftw: fastest FFT calculations with FFTW library'
+ 'python-scipy: faster FFT calculations with scipy.fftpack library'
+)
+source=(https://github.com/xmikos/simplespectral/archive/v$pkgver.tar.gz)
+sha256sums=('4342741f7054c71f7c5fb9d38df49e048e0a4e20eb53cefd247e47937644cad0')
+
+build() {
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python setup.py install --root="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: