summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gizdov2017-04-14 14:41:37 +0200
committerKonstantin Gizdov2017-04-14 14:41:37 +0200
commitc1b02c81d18fe23a3c2f74e6e9a5ac03751d1e6d (patch)
tree7238ac4d457a640e3316f71fbce45a0d8c52cc65
downloadaur-c1b02c81d18fe23a3c2f74e6e9a5ac03751d1e6d.tar.gz
initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD58
-rw-r--r--settings.cmake2
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4c416b36fa7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = simpletools
+ pkgdesc = Handy command line tools for ntuple manipulation and analysis.
+ pkgver = 2.0t.aee4f2f
+ pkgrel = 1
+ url = https://github.com/cofitzpa/simpletools
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = root
+ provides = simpletools
+ options = !emptydirs
+ source = simpletools::git+https://github.com/cofitzpa/simpletools
+ source = settings.cmake
+ sha256sums = SKIP
+ sha256sums = 540b86cd9997926026a5d277c819ae9c348bde7921158a78f3c676c855b6ab5e
+
+pkgname = simpletools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96045ee7e5d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Konstantin Gizdov < arch at kge dot pw >
+
+pkgname=simpletools
+pkgver=2.0t.aee4f2f
+pkgrel=1
+pkgdesc="Handy command line tools for ntuple manipulation and analysis."
+arch=('i686' 'x86_64')
+url="https://github.com/cofitzpa/simpletools"
+license=('GPL2')
+provides=('simpletools')
+depends=('root')
+source=("${pkgname}::git+https://github.com/cofitzpa/simpletools"
+ 'settings.cmake')
+sha256sums=('SKIP'
+ '540b86cd9997926026a5d277c819ae9c348bde7921158a78f3c676c855b6ab5e')
+options=('!emptydirs')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p "${srcdir}/${pkgname}/build"
+ cd "${srcdir}/${pkgname}/build"
+ msg2 'Configuring...'
+ cmake -C "${srcdir}/settings.cmake" "${srcdir}/${pkgname}"
+ # remove wrongly included ELF file
+ rm "${srcdir}/${pkgname}/simpletools_tutorial/core.17423"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}/build"
+ msg2 'Compiling...'
+ make
+}
+
+package() {
+ # Package does not define install script
+ msg2 'Installing...'
+ install -d "${pkgdir}/usr/bin/"
+ declare -a bins
+ bins=("${srcdir}/${pkgname}"/build/bin/*)
+ for bin in "${bins[@]}"; do
+ install -Dm755 "${bin}" "${pkgdir}/usr/bin/"
+ done
+ install -d "${pkgdir}/usr/lib/"
+ declare -a libs
+ libs=("${srcdir}/${pkgname}"/build/lib/*)
+ for lib in "${libs[@]}"; do
+ install -Dm755 "${lib}" "${pkgdir}/usr/lib/"
+ done
+ install -d "${pkgdir}/usr/share/simpletools/tutorial/"
+ declare -a tutorials
+ tutorials=("${srcdir}/${pkgname}"/simpletools_tutorial/*)
+ for tutorial in "${tutorials[@]}"; do
+ install -Dm644 "${tutorial}" "${pkgdir}/usr/share/simpletools/tutorial/"
+ done
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/simpletools/LICENSE"
+ install -Dm644 "${srcdir}/${pkgname}/README" "${pkgdir}/usr/share/doc/simpletools/README"
+ install -Dm644 "${srcdir}/${pkgname}/README.md" "${pkgdir}/usr/share/doc/simpletools/README.md"
+}
diff --git a/settings.cmake b/settings.cmake
new file mode 100644
index 000000000000..748e3b1d0c9e
--- /dev/null
+++ b/settings.cmake
@@ -0,0 +1,2 @@
+set (CMAKE_INSTALL_PREFIX /usr CACHE PATH "" FORCE)
+set (CMAKE_SKIP_RPATH ON CACHE BOOL "" FORCE)