summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRihards Skuja2020-06-04 23:11:54 +0300
committerRihards Skuja2020-06-04 23:33:14 +0300
commit435bc33799968b2f224cf3ec7168fa98161d61ff (patch)
tree238bad0e3b5eee1975b82880bf2bac487c48af0a
downloadaur-435bc33799968b2f224cf3ec7168fa98161d61ff.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0a865ade492
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = simplicity-commander
+ pkgdesc = GUI and command line access to the debug features of Silicon Labs devices
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = https://www.silabs.com/mcu/programming-options
+ arch = x86_64
+ license = LGPL
+ options = !strip
+ source = https://www.silabs.com/documents/public/software/SimplicityCommander-Linux.zip
+ sha256sums = 01f7aaf9c3f26f8dd09e24ab87e6fe7f0bb692951261b30498bf9b011dba6476
+
+pkgname = simplicity-commander
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b139d622d2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Rihards Skuja <rhssk at posteo dot eu>
+
+pkgname=simplicity-commander
+pkgver=1.10.0
+pkgrel=1
+pkgdesc='GUI and command line access to the debug features of Silicon Labs devices'
+arch=('x86_64')
+url='https://www.silabs.com/mcu/programming-options'
+license=('LGPL')
+options=('!strip')
+source=('https://www.silabs.com/documents/public/software/SimplicityCommander-Linux.zip')
+# No versioned archives are provided so this will break on every update...
+sha256sums=('01f7aaf9c3f26f8dd09e24ab87e6fe7f0bb692951261b30498bf9b011dba6476')
+
+package() {
+ cd "SimplicityCommander-Linux"
+ install -d "$pkgdir"/{usr/bin,opt}
+ tar -xjf Commander_linux_x86_64_*.tar.bz
+ cp -a "$srcdir/SimplicityCommander-Linux/commander" "$pkgdir/opt/$pkgname"
+ ln -s "/opt/$pkgname/commander" "$pkgdir/usr/bin/"
+}