summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHåvard Pettersson2018-11-11 01:23:03 +0100
committerHåvard Pettersson2018-11-11 01:23:03 +0100
commitf9d6b72b519a48feb541d9d741d51ab5d8b4e6d9 (patch)
tree20fdae434d238b019cd039d011d5d49f5bec5af2
parent9f3a977c3f20a3387453554fa76409a044a497b4 (diff)
downloadaur-f9d6b72b519a48feb541d9d741d51ab5d8b4e6d9.tar.gz
upgpkg: simplicitystudio 4-4
* Add --launcher.GTK_version 2 to studio.ini * Add webkitgtk2 dependency * Misc build script improvements
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD57
-rw-r--r--gtk-version-2.patch12
-rw-r--r--simplicitystudio7
-rw-r--r--simplicitystudio.desktop8
-rw-r--r--simplicitystudio.patch34
-rw-r--r--simplicitystudio.sh2
7 files changed, 66 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3caca6dceb78..d2738681e726 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,24 @@
-# Generated by mksrcinfo v8
-# Tue Feb 21 08:09:47 UTC 2017
pkgbase = simplicitystudio
pkgdesc = Design tools, documentation, software and support resources for EFM32™, EFM8™, 8051, Wireless MCUs and Wireless SoCs.
pkgver = 4
- pkgrel = 3
- url = https://www.silabs.com/products/mcu/Pages/simplicity-studio.aspx
- arch = i686
+ pkgrel = 4
+ url = https://www.silabs.com/products/development-tools/software/simplicity-studio
arch = x86_64
license = unknown
+ depends = lib32-gtk2
+ depends = lib32-libxtst
+ depends = lib32-qt4
+ depends = webkitgtk2
options = !strip
- source = http://www.silabs.com/Support%20Documents/Software/SimplicityStudio-v4.tgz
- source = simplicitystudio.patch
- source = simplicitystudio
- sha256sums = 68a3435165e6ab3f1ff935204cbf0c08a169ed544b97efda1ca310401311493b
- sha256sums = 0ccc9c084c82d99174980f299dc0f8a10249170060640ea19bec309a775f83c8
- sha256sums = ad55e8352d5d3d9cba50553086ca6d8b1d5072dc87b2763a79f34210f7bc2b5d
- depends_i686 = gtk2
- depends_i686 = libxtst
- depends_i686 = qt4
- depends_x86_64 = lib32-gtk2
- depends_x86_64 = lib32-libxtst
- depends_x86_64 = lib32-qt4
+ backup = opt/simplicitystudio/studio.ini
+ source = https://www.silabs.com/documents/login/software/SimplicityStudio-v4.tgz
+ source = gtk-version-2.patch
+ source = simplicitystudio.sh
+ source = simplicitystudio.desktop
+ sha256sums = ff58b0a78e9fb63cb12ce784b58c83ea62096981f21187c9b200edc0898216f9
+ sha256sums = 55445982b1940d3d6eb51ee5034313845c56d1540045ddd435649d51532eee66
+ sha256sums = bc844e45b04bd73f684206de38b67be186634b63a850cacd1e6ed374ae9c0579
+ sha256sums = c29c27fa0182b3c38e5be0830d634aca6ed6d88109695226471a5ef40165a622
pkgname = simplicitystudio
diff --git a/PKGBUILD b/PKGBUILD
index 33565ab652ea..35dd69dd8fb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,43 @@
pkgname=simplicitystudio
pkgver=4
-pkgrel=3
+pkgrel=4
pkgdesc='Design tools, documentation, software and support resources for EFM32™, EFM8™, 8051, Wireless MCUs and Wireless SoCs.'
-arch=(i686 x86_64)
-url='https://www.silabs.com/products/mcu/Pages/simplicity-studio.aspx'
-license=('unknown')
-
-depends_i686=(gtk2 libxtst qt4)
-depends_x86_64=(lib32-gtk2 lib32-libxtst lib32-qt4)
-
+arch=(x86_64)
+url=https://www.silabs.com/products/development-tools/software/simplicity-studio
+license=(unknown)
+backup=("opt/$pkgname/studio.ini")
+depends=(lib32-gtk2 lib32-libxtst lib32-qt4 webkitgtk2)
options=('!strip')
-
-source=(http://www.silabs.com/Support%20Documents/Software/SimplicityStudio-v4.tgz
- simplicitystudio.patch
- simplicitystudio)
-sha256sums=('68a3435165e6ab3f1ff935204cbf0c08a169ed544b97efda1ca310401311493b'
- '0ccc9c084c82d99174980f299dc0f8a10249170060640ea19bec309a775f83c8'
- 'ad55e8352d5d3d9cba50553086ca6d8b1d5072dc87b2763a79f34210f7bc2b5d')
+source=(https://www.silabs.com/documents/login/software/SimplicityStudio-v4.tgz
+ gtk-version-2.patch
+ simplicitystudio.sh
+ simplicitystudio.desktop)
+sha256sums=('ff58b0a78e9fb63cb12ce784b58c83ea62096981f21187c9b200edc0898216f9'
+ '55445982b1940d3d6eb51ee5034313845c56d1540045ddd435649d51532eee66'
+ 'bc844e45b04bd73f684206de38b67be186634b63a850cacd1e6ed374ae9c0579'
+ 'c29c27fa0182b3c38e5be0830d634aca6ed6d88109695226471a5ef40165a622')
prepare() {
- cd "$srcdir/SimplicityStudio_v4"
- patch -p1 -i "$srcdir/simplicitystudio.patch"
+ cd "$srcdir/SimplicityStudio_v4"
+ patch -p1 -i "$srcdir/gtk-version-2.patch"
}
package() {
- install -dm755 "$pkgdir/opt/"
- install -dm755 "$pkgdir/usr/share/applications/"
- install -dm755 "$pkgdir/etc/udev/rules.d"
+ install -dm755 "$pkgdir/opt/"
+ cp -a "$srcdir/SimplicityStudio_v4" "$pkgdir/opt/simplicitystudio"
- cp -a "$srcdir/SimplicityStudio_v4" "$pkgdir/opt/$pkgname"
+ install -dm755 "$pkgdir/etc/udev/rules.d/"
+ find "$srcdir/SimplicityStudio_v4/StudioLinux" -name '*.rules' \
+ -exec install -m644 {} "$pkgdir/etc/udev/rules.d/" \;
- DESTDIR="$pkgdir" "$pkgdir/opt/$pkgname/setup.sh"
+ install -Dm755 simplicitystudio.sh "$pkgdir/usr/bin/simplicitystudio"
+ install -Dm644 "simplicitystudio.desktop" \
+ "$pkgdir/usr/share/applications/simplicitystudio.desktop"
- # installation directory has to be writable
- find "$pkgdir/opt/$pkgname" -type d -exec chmod a+w {} +
- find "$pkgdir/opt/$pkgname" -type f -exec chmod a+w {} +
-
- install -Dm755 "$srcdir/simplicitystudio" "$pkgdir/usr/bin/$pkgname"
- sed -i "s/^pkgname=.*/pkgname=$pkgname/" "$pkgdir/usr/bin/$pkgname"
+ # installation directory has to be writable
+ find "$pkgdir/opt/simplicitystudio" -type d -exec chmod a+w {} +
+ find "$pkgdir/opt/simplicitystudio" -type f -exec chmod a+w {} +
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gtk-version-2.patch b/gtk-version-2.patch
new file mode 100644
index 000000000000..bc1e85366690
--- /dev/null
+++ b/gtk-version-2.patch
@@ -0,0 +1,12 @@
+diff -aur SimplicityStudio_v4/studio.ini SimplicityStudio_v4_patched/studio.ini
+--- SimplicityStudio_v4/studio.ini 2018-10-20 21:01:36.000000000 +0200
++++ SimplicityStudio_v4_patched/studio.ini 2018-11-10 19:20:37.650842382 +0100
+@@ -2,6 +2,8 @@
+ plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar
+ --launcher.library
+ plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.300.v20150602-1417
++--launcher.GTK_version
++2
+ -vm
+ jre/bin/java
+ -vmargs
diff --git a/simplicitystudio b/simplicitystudio
deleted file mode 100644
index d9bacb5555f1..000000000000
--- a/simplicitystudio
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-pkgname=simplicitystudio # set by PKGBUILD
-
-cd "/opt/$pkgname"
-exec ./studio "$@"
-
diff --git a/simplicitystudio.desktop b/simplicitystudio.desktop
new file mode 100644
index 000000000000..49b31f947b9c
--- /dev/null
+++ b/simplicitystudio.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=4
+Type=Application
+Terminal=false
+Exec=/usr/bin/simplicitystudio
+Name=Simplicity Studio
+Path=/opt/simplicitystudio
+Icon=/opt/simplicitystudio/icon.xpm
diff --git a/simplicitystudio.patch b/simplicitystudio.patch
deleted file mode 100644
index aecaa0d00228..000000000000
--- a/simplicitystudio.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -aur SimplicityStudio_v4/setup.sh SimplicityStudio_v4_patched/setup.sh
---- SimplicityStudio_v4/setup.sh 2016-10-21 13:55:59.000000000 -0700
-+++ SimplicityStudio_v4_patched/setup.sh 2016-11-01 10:35:31.898186828 -0700
-@@ -49,8 +49,8 @@
- chmod $mode "$folder/studio.desktop"
- }
-
--if [ -d "/usr/share/applications" ]; then
-- create_desktop_file "/usr/share/applications" root 644
-+if [ -d "$DESTDIR/usr/share/applications" ]; then
-+ create_desktop_file "$DESTDIR/usr/share/applications" root 644
- elif [ -d "$SUDO_HOME/.local/share/applications" ]; then
- create_desktop_file "$SUDO_HOME/.local/share/applications" "$SUDO_USER" 755
- elif [ -d "$SUDO_HOME/Desktop" ]; then
-@@ -62,8 +62,8 @@
- # Exit if /etc/udev/rules.d does not exist
- #
-
--if [ ! -d "/etc/udev/rules.d" ]; then
-- echo ERROR /etc/udev/rules.d does not exist
-+if [ ! -d "$DESTDIR/etc/udev/rules.d" ]; then
-+ echo ERROR $DESTDIR/etc/udev/rules.d does not exist
- exit 1
- fi
-
-@@ -78,7 +78,7 @@
- do
- rules_file=`basename "$rules_path"`
- echo "Installing udev $rules_file...";
-- cp "$rules_path" /etc/udev/rules.d
-+ cp "$rules_path" "$DESTDIR/etc/udev/rules.d"
- done
-
- # ------------------------------------------------------------------
diff --git a/simplicitystudio.sh b/simplicitystudio.sh
new file mode 100644
index 000000000000..03431119bd02
--- /dev/null
+++ b/simplicitystudio.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/env sh
+exec /opt/simplicitystudio/run_studio.sh