summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli2020-11-14 20:46:33 +0100
committerDenis 'GNUtoo' Carikli2020-11-14 21:08:59 +0100
commit793c13018158cc5b5df1c7b0e7d237eabaf0d7b0 (patch)
tree38adc003159a49a09ca721bce69c963ca30609f3
parent55fb28ed0972a413cb3a17bb07c668c9bbdd7587 (diff)
downloadaur-793c13018158cc5b5df1c7b0e7d237eabaf0d7b0.tar.gz
Switch to 1.5 release
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c2572f6bb9a..1e6c25dd5644 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-pkgbase = simtrace-git
+pkgbase = simtrace
pkgdesc = Traces the communication between phones and SIM cards with first generation simtrace hardware.
- pkgver = 0.1.r89.g6fde8e1
- pkgrel = 2
- url = http://bb.osmocom.org/trac/wiki/SIMtrace
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://osmocom.org/projects/simtrace/wiki/SIMtrace
arch = armv7h
arch = i686
arch = x86_64
@@ -13,9 +13,11 @@ pkgbase = simtrace-git
makedepends = pkg-config
depends = libosmocore
depends = libusb
+ depends = lksctp-tools
depends = talloc
- source = git://git.osmocom.org/simtrace.git#commit=6fde8e1c26f12069e67103ba5f69a068d78de063
+ replaces = simtrace-git
+ source = git://git.osmocom.org/simtrace.git#tag=v1.5
sha512sums = SKIP
-pkgname = simtrace-git
+pkgname = simtrace
diff --git a/PKGBUILD b/PKGBUILD
index 34b5697bfd67..c0d804b63aff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,27 @@
-# Copyright (C) 2019 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# Copyright (C) 2020 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
-pkgname=simtrace-git
-_pkgname=simtrace
-pkgver=0.1.r89.g6fde8e1
-_commit=6fde8e1c26f12069e67103ba5f69a068d78de063
-pkgrel=2
+pkgname=simtrace
+pkgver=1.5
+pkgrel=1
pkgdesc="Traces the communication between phones and SIM cards with first generation simtrace hardware."
arch=('armv7h' 'i686' 'x86_64')
-url="http://bb.osmocom.org/trac/wiki/SIMtrace"
+url="https://osmocom.org/projects/simtrace/wiki/SIMtrace"
license=('GPL2') # GPLv2-only according to the source files headers
-depends=('libosmocore' 'libusb' 'talloc')
+replaces=('simtrace-git')
+depends=('libosmocore' 'libusb' 'lksctp-tools' 'talloc')
makedepends=('make' 'gcc' 'git' 'pkg-config')
-source=("git://git.osmocom.org/simtrace.git#commit=$_commit")
+source=("git://git.osmocom.org/simtrace.git#tag=v$pkgver")
sha512sums=('SKIP')
-pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
build() {
- cd "$srcdir/$_pkgname/host"
+ cd "$srcdir/$pkgname/host"
make
}
package() {
- cd "$srcdir/$_pkgname/host"
+ cd "$srcdir/$pkgname/host"
make DESTDIR=$pkgdir install
}