summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Demartino2018-06-27 00:57:52 -0300
committerFrancisco Demartino2018-06-27 00:58:19 -0300
commit73f653f2d4139505b5d7b1ac2e4f4946b3a2b56e (patch)
tree4a8c85bfa5afa191f6401b7a9d9450b3233a26d6
downloadaur-73f653f2d4139505b5d7b1ac2e4f4946b3a2b56e.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7356f26315a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = simulide
+ pkgdesc = Real time electronic circuit simulator (supports PIC, AVR and Arduino microcontrollers)
+ pkgver = 0.1.7
+ pkgrel = 1
+ url = http://simulide.blogspot.com/
+ arch = x86_64
+ license = GPL3
+ depends = gpsim
+ depends = qt5-multimedia
+ depends = qt5-serialport
+ depends = qt5-svg
+ source = https://sourceforge.net/projects/simulide/files/SimulIDE_0.1.7/simulide_0.1.7-Sources.tar.gz
+ md5sums = 61c260374ae0e7733f867349b7990acf
+
+pkgname = simulide
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93f5d9f2777e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b8a7e6f8f4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Francisco Demartino <demartino.francisco@gmail.com>
+
+pkgname=simulide
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="Real time electronic circuit simulator (supports PIC, AVR and Arduino microcontrollers)"
+arch=('x86_64')
+url="http://simulide.blogspot.com/"
+license=('GPL3')
+source=("https://sourceforge.net/projects/${pkgname}/files/SimulIDE_${pkgver}/${pkgname}_${pkgver}-Sources.tar.gz")
+md5sums=('61c260374ae0e7733f867349b7990acf')
+depends=(
+'gpsim'
+'qt5-multimedia'
+'qt5-serialport'
+'qt5-svg'
+)
+
+build() {
+ cd ${srcdir}/${pkgname}_${pkgver}/build_XX
+ qmake
+ make
+}
+
+package() {
+ cp -r ${srcdir}/${pkgname}_${pkgver}/build_XX/release/SimulIDE_${pkgver} ${pkgdir}/usr
+ ln -s SimulIDE_${pkgver} ${pkgdir}/usr/bin/simulide
+}