summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoboron30422020-10-23 00:06:01 +0200
committerRoboron30422020-10-23 00:06:01 +0200
commitc763fd90d6ab23acaedd040344b84b0a72b44ccf (patch)
treea8faf3f33f4c1109ad2e9338fa2b86da6883acd3
parent4278876650344e8c5d00bac51daf9fa9fce1a693 (diff)
downloadaur-c763fd90d6ab23acaedd040344b84b0a72b44ccf.tar.gz
patch fix, improved explanation
-rw-r--r--.SRCINFO4
-rw-r--r--How to add files and paksets.md10
-rw-r--r--PKGBUILD4
-rw-r--r--path-for-game-data.patch16
4 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ee40f7719a1..e6d2063760d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -46,10 +46,10 @@ pkgbase = simutrans-nightly
sha256sums = SKIP
sha256sums = c0c2dd5da146f64901b00c6ee67e0818a166b983a81cee7897c4843aa9f21c81
sha256sums = 671398550f46525ef0dae338d9e1984bfc0e1ec36153e1c4163c8c35de240c7e
- sha256sums = 61ce1dab7d1b7d161eb032d9fb4ed929236ff45669f1aaec33fbdb978baa1365
+ sha256sums = 9898a1bc8062f18e393edb0c81d0caa31d158ed6fa39a51ff7e3f10f1e981156
sha256sums = d85cce5c473131912f749f4c632932e0d5cac8d338babf5d9279f42ceea76fca
sha256sums = 99545152f5e739b7eb028152383fa10d3e3d303c99167e1c6e5a6bd7dcd00fa3
- sha256sums = f933d5608052b73e03e21d4ade0909e471c643ee5493023921fa5bc963a06ab3
+ sha256sums = 52a00091a71e250205adcb3ef8b86b560a5c27429ec700c5e5242f58184d90ab
pkgname = simutrans-nightly
diff --git a/How to add files and paksets.md b/How to add files and paksets.md
index 6ce40e30daf4..15f10f3a0385 100644
--- a/How to add files and paksets.md
+++ b/How to add files and paksets.md
@@ -1,3 +1,9 @@
+# Preserving your game configuration
+
+To preserve your game config you need to copy `/usr/share/games/simutrans/config/simuconf.tab` to `~/.config/simutrans/simuconf.tab`. Otherwise, the original simuconf.tab file will be **overwrited** with every update.
+
+Additionally, you can also add non-pakset files (fonts, music, etc) in `~/.config/simutrans`
+
# Adding files in the user data directory (~/.local/share/simutrans)
Files in this directory are symlinked from `/usr/share/games/simutrans` (shared Simutrans Standard installation)
@@ -12,7 +18,3 @@ Symlinked files are updated everytime you open the game, so:
2. New paksets installed will be picked up automatically.
But please **don't replace symlinked files in this directory**. You will lose your replaced files when you open Simutrans! Instead, if you want, for example, to install another version of "pak64" rename it to "pak64-myversion".
-
-# Adding files in the user config directory (~/.config/simutrans)
-
-Additionally, you can also add non-pakset files (fonts, music, etc) in `~/.config/simutrans`
diff --git a/PKGBUILD b/PKGBUILD
index 17588ac3325d..5660c3684aee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,10 +43,10 @@ source=(git+https://github.com/aburch/simutrans
sha256sums=('SKIP'
'c0c2dd5da146f64901b00c6ee67e0818a166b983a81cee7897c4843aa9f21c81'
'671398550f46525ef0dae338d9e1984bfc0e1ec36153e1c4163c8c35de240c7e'
- '61ce1dab7d1b7d161eb032d9fb4ed929236ff45669f1aaec33fbdb978baa1365'
+ '9898a1bc8062f18e393edb0c81d0caa31d158ed6fa39a51ff7e3f10f1e981156'
'd85cce5c473131912f749f4c632932e0d5cac8d338babf5d9279f42ceea76fca'
'99545152f5e739b7eb028152383fa10d3e3d303c99167e1c6e5a6bd7dcd00fa3'
- 'f933d5608052b73e03e21d4ade0909e471c643ee5493023921fa5bc963a06ab3')
+ '52a00091a71e250205adcb3ef8b86b560a5c27429ec700c5e5242f58184d90ab')
prepare() {
# Some files are distributed in DOS format
diff --git a/path-for-game-data.patch b/path-for-game-data.patch
index 8266c86ee957..105f655d9e8e 100644
--- a/path-for-game-data.patch
+++ b/path-for-game-data.patch
@@ -1,10 +1,12 @@
---- simmain.cc.orig 2020-08-31 22:27:22.631270676 +0200
-+++ simmain.cc 2020-10-14 12:38:44.360649459 +0200
+Index: simmain.cc
+===================================================================
+--- simmain.cc (revisiĆ³n: 9320)
++++ simmain.cc (copia de trabajo)
@@ -428,6 +428,11 @@
env_t::init();
-++ // Make simutrans re-symlinks the files when opened
++ // Make simutrans re-symlinks the files when opened
+#ifdef __linux__
+ system("\cp -rs --remove-destination /usr/share/games/simutrans/ ~/.local/share/");
+#endif
@@ -12,12 +14,12 @@
// you really want help with this?
if (gimme_arg(argc, argv, "-h", 0) ||
gimme_arg(argc, argv, "-?", 0) ||
-@@ -513,8 +518,9 @@
- strcat( env_t::program_dir, PATH_SEPARATOR );
+@@ -515,8 +520,9 @@
+ strcat( env_t::data_dir, PATH_SEPARATOR );
}
else {
-- strcpy( env_t::program_dir, argv[0] );
-- *(strrchr( env_t::program_dir, PATH_SEPARATOR[0] )+1) = 0;
+- strcpy( env_t::data_dir, argv[0] );
+- *(strrchr( env_t::data_dir, PATH_SEPARATOR[0] )+1) = 0;
+ static char buffer[100];
+ sprintf(buffer, "%s/.local/share/simutrans/", getenv("HOME"));
+ strcpy(env_t::program_dir, buffer);