summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoboron30422021-02-12 02:21:37 +0100
committerRoboron30422021-02-12 02:21:37 +0100
commit432471588598bfd3ae56abb241cb8b2dac4a466d (patch)
tree8f25961f2a19c626598db1afc5645e1fc67f6c27
parent6e18d9d5b679bd4e36c36ede7775e5e2272ef22d (diff)
downloadaur-432471588598bfd3ae56abb241cb8b2dac4a466d.tar.gz
Introducing Fluidsynth
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--config.patch61
-rw-r--r--simutrans-svn.install6
4 files changed, 12 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c726b07d4af5..c945837345a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = simutrans-svn
pkgdesc = Transportation simulation game - Nightly build from SVN
- pkgver = r9617
+ pkgver = r9625
pkgrel = 1
url = https://www.simutrans.com/
- install = simutrans-svn.install
arch = any
license = custom:Artistic
makedepends = subversion
makedepends = pkgconf
+ makedepends = autoconf
+ makedepends = make
depends = gcc-libs
depends = zstd
depends = zlib
@@ -15,7 +16,8 @@ pkgbase = simutrans-svn
depends = hicolor-icon-theme
depends = freetype2
depends = miniupnpc
- optdepends = fluidsynth: play MIDI music
+ depends = fluidsynth
+ optdepends = freepats-general-midi: recommended MIDI soundfont
optdepends = simutrans-pak32.comic: Lowest resolution graphics set for Simutrans
optdepends = simutrans-pak48.excentrique: Low resolution graphics set for Simutrans, with an eccentric theme
optdepends = simutrans-pak64: Low resolution graphics set for Simutrans
@@ -38,13 +40,11 @@ pkgbase = simutrans-svn
source = svn+svn://servers.simutrans.org/simutrans/trunk
source = settings-folder.patch
source = path-for-game-data.patch
- source = config.patch
source = simutrans.desktop
source = How to add files and paksets.md
sha256sums = SKIP
sha256sums = 671398550f46525ef0dae338d9e1984bfc0e1ec36153e1c4163c8c35de240c7e
sha256sums = cb9fda1a99d0b54f316ba5ea5b90ec658641f9a9d3b77faf981525e12ff99188
- sha256sums = 0a5fef72b8d4d3fce4454e6411e2b620104b3b0e3f57732873d14b9f51001176
sha256sums = 99545152f5e739b7eb028152383fa10d3e3d303c99167e1c6e5a6bd7dcd00fa3
sha256sums = 52a00091a71e250205adcb3ef8b86b560a5c27429ec700c5e5242f58184d90ab
diff --git a/PKGBUILD b/PKGBUILD
index 00d7c3a95f15..9c19395f64d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Roboron <robertoms258 at gmail dot com>
pkgname=simutrans-svn
-pkgver=r9617
+pkgver=r9625
pkgrel=1
pkgdesc="Transportation simulation game - Nightly build from SVN"
arch=('any')
url="https://www.simutrans.com/"
license=('custom:Artistic')
-install="$pkgname.install"
-depends=('gcc-libs' 'zstd' 'zlib' 'sdl2_mixer' 'hicolor-icon-theme' 'freetype2' 'miniupnpc')
-makedepends=('subversion' 'pkgconf')
-optdepends=('fluidsynth: play MIDI music'
+depends=('gcc-libs' 'zstd' 'zlib' 'sdl2_mixer' 'hicolor-icon-theme' 'freetype2' 'miniupnpc' 'fluidsynth')
+makedepends=('subversion' 'pkgconf' 'autoconf' 'make')
+optdepends=('freepats-general-midi: recommended MIDI soundfont'
'simutrans-pak32.comic: Lowest resolution graphics set for Simutrans'
'simutrans-pak48.excentrique: Low resolution graphics set for Simutrans, with an eccentric theme'
'simutrans-pak64: Low resolution graphics set for Simutrans'
@@ -34,13 +33,11 @@ conflicts=('simutrans')
source=(svn+svn://servers.simutrans.org/simutrans/trunk
settings-folder.patch
path-for-game-data.patch
- config.patch
simutrans.desktop
"How to add files and paksets.md")
sha256sums=('SKIP'
'671398550f46525ef0dae338d9e1984bfc0e1ec36153e1c4163c8c35de240c7e'
'cb9fda1a99d0b54f316ba5ea5b90ec658641f9a9d3b77faf981525e12ff99188'
- '0a5fef72b8d4d3fce4454e6411e2b620104b3b0e3f57732873d14b9f51001176'
'99545152f5e739b7eb028152383fa10d3e3d303c99167e1c6e5a6bd7dcd00fa3'
'52a00091a71e250205adcb3ef8b86b560a5c27429ec700c5e5242f58184d90ab')
@@ -50,20 +47,18 @@ prepare() {
# Adjust paths
patch -Np0 -i ../settings-folder.patch
patch -Np0 -i ../path-for-game-data.patch
-
- # Configure the build process
- cp config.template config.default
- patch -Np0 -i ../config.patch
}
build() {
cd trunk
+ autoconf
+ ./configure
make
}
package() {
#binary
- install -Dm755 trunk/build/default/sim "$pkgdir/usr/bin/simutrans"
+ install -Dm755 trunk/sim "$pkgdir/usr/bin/simutrans"
#data
mkdir -p "$pkgdir/usr/share/games/simutrans"
diff --git a/config.patch b/config.patch
deleted file mode 100644
index 8b2b131d3bca..000000000000
--- a/config.patch
+++ /dev/null
@@ -1,61 +0,0 @@
---- config.default.orig 2020-12-30 13:56:52.910168682 +0100
-+++ config.default 2020-12-30 14:22:16.056031632 +0100
-@@ -12,7 +12,7 @@
- #BACKEND = gdi
- #BACKEND = sdl
- #BACKEND = sdl2
--#BACKEND = mixer_sdl
-+BACKEND = mixer_sdl2
- #BACKEND = mixer_sdl2
- #BACKEND = posix
-
-@@ -21,41 +21,41 @@
- #OSTYPE = cygwin
- #OSTYPE = freebsd
- #OSTYPE = haiku
--#OSTYPE = linux
-+OSTYPE = linux
- #OSTYPE = mingw
- #OSTYPE = mac
-
- #DEBUG = 1 # Level 1-3, higher number means more debug-friendly but slower, see Makefile
- #MSG_LEVEL = 1 # Level 1-4, more runtime debug messages (without only warnings and errors)
--#OPTIMISE = 1 # Add umpteen optimisation flags
-+OPTIMISE = 1 # Add umpteen optimisation flags
- #PROFILE = 1 # Enable profiling
- #PROFILE = 2 # Enable profiling with optimisation flags, can be used with `OPTIMISE = 1'
-
- #STATIC = 1 # Enable static linkage, currently mingw only
- #AV_FOUNDATION = 1 # Use AVFoundation instead of QTKit. If you are using macOS 10.12 or later, this must be enabled.
-
--#WITH_REVISION = 1 # adds the revision from svn; required for networkgames
-+WITH_REVISION = 1 # adds the revision from svn; required for networkgames
- # if you do not use SVN, add -DREVISION="1234" to the FLAGS below
-
- #WIN32_CONSOLE = 1 # adds a console for windows debugging
-
--#MULTI_THREAD = 1 # Enable multithreading
-+MULTI_THREAD = 1 # Enable multithreading
-
- # using freetype for Truetype font support
--USE_FREETYPE = 0
-+USE_FREETYPE = 1
-
- # using UPnP for easy server hosting behind routers
--#USE_UPNP = 0
-+USE_UPNP = 1
-
- # using zstd compression library
--#USE_ZSTD = 0
-+USE_ZSTD = 1
-
- # Define these as empty strings, if you don't have the respective config program
- #ALLEGRO_CONFIG = allegro-config
- #PNG_CONFIG = pkg-config libpng
- #SDL_CONFIG = sdl-config
- #SDL2_CONFIG = sdl2-config
--#FREETYPE_CONFIG = freetype-config
-+FREETYPE_CONFIG = pkg-config freetype2
-
- #VERBOSE = 1
-
diff --git a/simutrans-svn.install b/simutrans-svn.install
deleted file mode 100644
index 0f4dbe1a2827..000000000000
--- a/simutrans-svn.install
+++ /dev/null
@@ -1,6 +0,0 @@
-post_install() {
-
- echo "To play MIDI music, along with fluidsynth, you will need to install a soundfont and set SDL_SOUNDFONTS=/path/to/soundfont"
- echo "For example, with soundfont-fluid: SDL_SOUNDFONTS=/usr/share/soundfonts/FluidR3_GM.sf2 simutrans"
- echo "Check the wiki to get more info about fluidsynth https://wiki.archlinux.org/index.php/FluidSynth"
-}