summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Dossena2016-02-10 13:22:23 +0100
committerFederico Dossena2016-02-10 13:22:23 +0100
commit124d6df78144130a94ca87179464cec5bc3f063c (patch)
treea35c4f82d379475c153c0a9fb0792740b9927ca5
downloadaur-124d6df78144130a94ca87179464cec5bc3f063c.tar.gz
Uploaded to AUR
-rwxr-xr-x.SRCINFO34
-rwxr-xr-xPKGBUILD39
-rwxr-xr-xeditor.pngbin0 -> 5417 bytes
-rwxr-xr-xpreset-mime.xml8
-rwxr-xr-xpreset.pngbin0 -> 14251 bytes
-rwxr-xr-xsine2
-rwxr-xr-xsine-cli2
-rwxr-xr-xsine-editor2
-rwxr-xr-xsine-editor.desktop10
-rwxr-xr-xsine.desktop11
-rwxr-xr-xsine.install11
-rwxr-xr-xsine.pngbin0 -> 5815 bytes
12 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..9269991c6a66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+# Generated by mksrcinfo v8
+# Wed Feb 10 12:18:43 UTC 2016
+pkgbase = sine
+ pkgdesc = Brainwave Entrainment Application
+ pkgver = latest
+ pkgrel = 1
+ url = http://sine.adolfintel.com
+ install = sine.install
+ arch = any
+ license = GPL3
+ depends = java-runtime
+ source = sine
+ source = sine-cli
+ source = sine-editor
+ source = sine.desktop
+ source = sine-editor.desktop
+ source = sine.png
+ source = editor.png
+ source = preset.png
+ source = preset-mime.xml
+ source = http://downloads.adolfintel.com/geth.php?r=sine-pcbin
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = sine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..7aa8651fd22a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=sine
+pkgver=latest
+pkgrel=1
+pkgdesc="Brainwave Entrainment Application"
+arch=(any)
+depends=('java-runtime')
+license=('GPL3')
+url='http://sine.adolfintel.com'
+source=(sine sine-cli sine-editor sine.desktop sine-editor.desktop sine.png editor.png preset.png preset-mime.xml http://downloads.adolfintel.com/geth.php?r=sine-pcbin)
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+install=sine.install
+
+package() {
+ cd "$srcdir"
+ echo "$pkgdir $srcdir"
+
+ rm -f "${srcdir}/"geth.*
+ rm -f "${srcdir}/"*.txt
+ rm -f "${srcdir}/"*.md
+
+ mkdir -p "${pkgdir}/usr/share/sine/"
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ mkdir -p "${pkgdir}/usr/bin/"
+
+ cp -LRf "${srcdir}/"* "${pkgdir}/usr/share/sine/"
+ mv "${pkgdir}/usr/share/sine/sine" "${pkgdir}/usr/bin/SINE"
+ mv "${pkgdir}/usr/share/sine/sine-cli" "${pkgdir}/usr/bin/SINE-CLI"
+ mv "${pkgdir}/usr/share/sine/sine-editor" "${pkgdir}/usr/bin/SINE-Editor"
+ chmod 755 "${pkgdir}/usr/bin/SINE"
+ chmod 755 "${pkgdir}/usr/bin/SINE-CLI"
+ chmod 755 "${pkgdir}/usr/bin/SINE-Editor"
+ chmod -R 755 "${pkgdir}/usr/share/sine/lib"*
+ chmod 755 "${pkgdir}/usr/share/sine/"*.jar
+ chmod -R 644 "${pkgdir}/usr/share/sine/editor_manual/"*
+ mv "${pkgdir}/usr/share/sine/"*.desktop "${pkgdir}/usr/share/applications/"
+
+
+}
+
diff --git a/editor.png b/editor.png
new file mode 100755
index 000000000000..23774b4cd4dd
--- /dev/null
+++ b/editor.png
Binary files differ
diff --git a/preset-mime.xml b/preset-mime.xml
new file mode 100755
index 000000000000..7fb266af7cdd
--- /dev/null
+++ b/preset-mime.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0"?>
+ <mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-sine">
+ <comment>SINE Preset</comment>
+ <glob pattern="*.sin"/>
+ </mime-type>
+ </mime-info>
+ \ No newline at end of file
diff --git a/preset.png b/preset.png
new file mode 100755
index 000000000000..a7a2b018b25b
--- /dev/null
+++ b/preset.png
Binary files differ
diff --git a/sine b/sine
new file mode 100755
index 000000000000..25c05dc76ac7
--- /dev/null
+++ b/sine
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar /usr/share/sine/SINE.jar "$@"
diff --git a/sine-cli b/sine-cli
new file mode 100755
index 000000000000..a2fae11b3e50
--- /dev/null
+++ b/sine-cli
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar /usr/share/sine/SINE-CLI.jar "$@"
diff --git a/sine-editor b/sine-editor
new file mode 100755
index 000000000000..1a7115c66777
--- /dev/null
+++ b/sine-editor
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar /usr/share/sine/SINE-Editor.jar "$@"
diff --git a/sine-editor.desktop b/sine-editor.desktop
new file mode 100755
index 000000000000..5ca18d1f4043
--- /dev/null
+++ b/sine-editor.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.8.4
+Name=SINE Editor
+Comment=Brainwave Entrainment Application
+Path=/usr/share/sine
+Exec=SINE-Editor
+Icon=sine-editor
+Terminal=false
+Categories=AudioVideo;AudioVideoEdit;
diff --git a/sine.desktop b/sine.desktop
new file mode 100755
index 000000000000..e0c192146087
--- /dev/null
+++ b/sine.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.8.4
+Name=SINE Isochronic Entrainer
+Comment=Brainwave Entrainment Application
+Path=/usr/share/sine
+Exec=SINE
+Icon=sine
+Terminal=false
+Categories=AudioVideo;Audio;
+MimeType=application/x-sine
diff --git a/sine.install b/sine.install
new file mode 100755
index 000000000000..2c087d2dc3f7
--- /dev/null
+++ b/sine.install
@@ -0,0 +1,11 @@
+post_install() {
+ cd "/usr/share/sine"
+ xdg-icon-resource install --context mimetypes --size 256 preset.png application-x-sine
+ xdg-mime install preset-mime.xml
+ xdg-icon-resource install --novendor --size 256 sine.png sine
+ xdg-icon-resource install --novendor --size 256 editor.png sine-editor
+}
+pre_remove() {
+ cd "/usr/share/sine"
+ xdg-mime uninstall preset-mime.xml
+}
diff --git a/sine.png b/sine.png
new file mode 100755
index 000000000000..7649c96a5ab5
--- /dev/null
+++ b/sine.png
Binary files differ