summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorswyter2015-06-10 21:09:09 +0200
committerswyter2015-06-10 21:09:09 +0200
commit03cc277ef7bf74a09e78ea661e06daf91eaeb5ac (patch)
tree71fbb9d26b132c6130e70ba549934f6217b85704
downloadaur-03cc277ef7bf74a09e78ea661e06daf91eaeb5ac.tar.gz
*let's see how it works out :)
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD61
-rw-r--r--sinerider.desktop12
-rw-r--r--sinerider.install13
4 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94b923553c63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = sinerider
+ pkgdesc = A game of numerical sledding. It will make you see math the way mathematicians see it: a creative process of exploration and discovery. Math is the ultimate puzzle, and SineRider is the ultimate math puzzle game.
+ pkgver = 0.3.36
+ pkgrel = 1
+ url = http://sineridergame.com/
+ install = sinerider.install
+ arch = x86_64
+ arch = i686
+ license = custom:freeware
+ license = unknown
+ depends = glibc
+ depends = glu
+ depends = libgl
+ depends = libx11
+ depends = libxext
+ depends = libxcursor
+ depends = libxrandr
+ depends = gcc-libs
+ depends = expat
+ depends = libglapi
+ depends = libxdamage
+ depends = libxfixes
+ depends = libxcb
+ depends = libxshmfence
+ depends = libxxf86vm
+ depends = libdrm
+ depends = libxrender
+ depends = libxau
+ depends = libxdmcp
+ source = https://s3.amazonaws.com/sinerider/SineRider+Linux.zip
+ source = sinerider.desktop
+ md5sums = 4f7066ce13d50e91b42b0b2e27260f34
+ md5sums = 778d8fd98d2a051882220c7b55bd0846
+
+pkgname = sinerider
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..914230bfdf1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: swyter <swyterzone+aur@gmail.com>
+# Note: Haven't really tested it with i686, but it should work all the same... at least in theory. :)
+
+pkgname=sinerider
+pkgver=0.3.36
+pkgrel=1
+epoch=
+pkgdesc="A game of numerical sledding. It will make you see math the way mathematicians see it: a creative process of exploration and discovery. Math is the ultimate puzzle, and SineRider is the ultimate math puzzle game."
+arch=('x86_64' 'i686')
+url="http://sineridergame.com/"
+license=('custom:freeware' 'unknown')
+groups=()
+depends=('glibc' 'glu' 'libgl' 'libx11' 'libxext' 'libxcursor' 'libxrandr' 'gcc-libs' 'expat' 'libglapi' 'libxdamage' 'libxfixes' 'libxcb' 'libxshmfence' 'libxxf86vm' 'libdrm' 'libxrender' 'libxau' 'libxdmcp')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+source=("https://s3.amazonaws.com/sinerider/SineRider+Linux.zip" "sinerider.desktop")
+md5sums=("4f7066ce13d50e91b42b0b2e27260f34"
+ "778d8fd98d2a051882220c7b55bd0846")
+install=sinerider.install
+
+package()
+{
+ # look up table from unity3d's silly arch nomenclature
+ declare -A archlut=([x86_64]="x86_64" [i686]="x86")
+
+ # mosly optional
+ cd "$srcdir"
+
+ # create the main folder
+ install -d "$pkgdir/opt/sinerider"
+
+ # copy the engine assets...
+ cp -rp "$srcdir/SineRider_Data" "$pkgdir/opt/sinerider/"
+
+ # ...and the right executable, depending on our current arch
+ install -Dm 755 "SineRider.${archlut[$CARCH]}" "$pkgdir/opt/sinerider/SineRider.$CARCH"
+
+ # remove unneeded stuff from the other arch
+ # unset the platform we're using from the look-up array,
+ # get the value of the other index and use it to delete anything we want.
+
+ unset archlut[$CARCH]
+ otherarch=${archlut[${!archlut[@]}]}
+
+ rm -rf "$pkgdir/opt/sinerider/SineRider_Data/Mono/$otherarch"
+ rm -rf "$pkgdir/opt/sinerider/SineRider_Data/Plugins/$otherarch"
+
+ # sundry icons and symlinked launcher
+ install -d "$pkgdir/usr/bin"
+ echo "/opt/sinerider/SineRider.$CARCH" > "$pkgdir/usr/bin/sinerider"
+ chmod +x "$pkgdir/usr/bin/sinerider"
+
+ install -Dm 755 "sinerider.desktop" "$pkgdir/usr/share/applications/sinerider.desktop"
+ install -Dm 644 "$srcdir/SineRider_Data/Resources/UnityPlayer.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/sinerider.png"
+}
diff --git a/sinerider.desktop b/sinerider.desktop
new file mode 100644
index 000000000000..f972e0390c74
--- /dev/null
+++ b/sinerider.desktop
@@ -0,0 +1,12 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Terminal=false
+Type=Application
+Name=SineRider
+Comment=SineRider is a game of numerical sledding.
+Exec=sinerider
+Icon=sinerider
+Categories=Game;Education;Math
+StartupWMClass=SineRider
+
diff --git a/sinerider.install b/sinerider.install
new file mode 100644
index 000000000000..164652586ef4
--- /dev/null
+++ b/sinerider.install
@@ -0,0 +1,13 @@
+# Maintainers: swyter <swyterzone+aur@gmail.com>
+
+post_upgrade()
+{
+ # make the svg icon appear correctly without having to wait for a restart:
+ gtk-update-icon-cache -f "/usr/share/icons/hicolor"
+}
+post_install()
+{
+ # call that thing up there :)
+ post_upgrade
+}
+