summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2021-10-18 14:15:11 +0200
committernaetherm2021-10-18 14:15:11 +0200
commitaa599d3c2df1b37d0a6ef2772f4ad7815a4a2736 (patch)
tree1742bdd381579c5a620d60f786bd1f053d65ce8b
downloadaur-aa599d3c2df1b37d0a6ef2772f4ad7815a4a2736.tar.gz
Version 20.3.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--singlebox.desktop.patch10
-rw-r--r--singlebox.sh3
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ecfa81247bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = singlebox-appimage
+ pkgdesc = All-in-One Messenger
+ pkgver = 20.3.2
+ pkgrel = 1
+ url = https://webcatalog.io/singlebox/
+ arch = x86_64
+ license = MIT
+ provides = singlebox=20.3.2
+ conflicts = singlebox
+ conflicts = singlebox-bin
+ options = !strip
+ source = https://cdn-2.webcatalog.io/singlebox/Singlebox-20.3.2.AppImage
+ source = singlebox.desktop.patch
+ source = singlebox.sh
+ sha256sums = 5e53212340f718074b39afd724abe38d1aa0097d4a9a06ebbacee2ab392a2bb3
+ sha256sums = 7cd20bcac165714b8128aefc57df29faae58ab1f829e4f4acdbdb3c8100ac7bd
+ sha256sums = a48c0cd52b212fbecca39a6066a2a8d0ddd21abea0d769c727d727f775ed3b9b
+
+pkgname = singlebox-appimage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..502096526701
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=singlebox-appimage
+pkgver=20.3.2
+pkgrel=1
+pkgdesc='All-in-One Messenger'
+arch=('x86_64')
+url='https://webcatalog.io/singlebox/'
+license=('MIT')
+provides=("singlebox=${pkgver}")
+conflicts=('singlebox' 'singlebox-bin')
+source=("https://cdn-2.webcatalog.io/singlebox/Singlebox-${pkgver}.AppImage"
+ "singlebox.desktop.patch"
+ "singlebox.sh")
+sha256sums=('5e53212340f718074b39afd724abe38d1aa0097d4a9a06ebbacee2ab392a2bb3'
+ '7cd20bcac165714b8128aefc57df29faae58ab1f829e4f4acdbdb3c8100ac7bd'
+ 'a48c0cd52b212fbecca39a6066a2a8d0ddd21abea0d769c727d727f775ed3b9b')
+options=(!strip)
+
+_filename=./Singlebox-${pkgver}.AppImage
+
+prepare() {
+ cd "${srcdir}"
+ chmod +x ${_filename}
+ ${_filename} --appimage-extract
+ patch -Np0 < ./singlebox.desktop.patch
+}
+
+
+package() {
+ install -Dm755 "${srcdir}/${_filename}" "${pkgdir}/opt/appimages/singlebox.AppImage"
+ install -Dm755 "${srcdir}/singlebox.sh" "${pkgdir}/usr/bin/singlebox"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ cp -r --no-preserve=mode,ownership "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+
+ install -Dm644 "${srcdir}/squashfs-root/singlebox.desktop" "${pkgdir}/usr/share/applications/singlebox.desktop"
+}
diff --git a/singlebox.desktop.patch b/singlebox.desktop.patch
new file mode 100644
index 000000000000..e62b3d9abe6a
--- /dev/null
+++ b/singlebox.desktop.patch
@@ -0,0 +1,10 @@
+--- squashfs-root/singlebox.desktop
++++ squashfs-root/singlebox.desktop
+@@ -1,6 +1,6 @@
+ [Desktop Entry]
+ Name=Singlebox
+-Exec=AppRun --no-sandbox %U
++Exec=/usr/bin/singlebox %F
+ Terminal=false
+ Type=Application
+ Icon=singlebox
diff --git a/singlebox.sh b/singlebox.sh
new file mode 100644
index 000000000000..d7842bf91d3e
--- /dev/null
+++ b/singlebox.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+/opt/appimages/singlebox.AppImage "$@"
+