summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2024-04-09 09:25:41 +0200
committerMarco Rubin2024-04-09 09:25:41 +0200
commit2e5f8c695846249a2fa4b1018442d0d8ba37a9a0 (patch)
treeb9cafd6a93d3d349d2b31ae437ab1426abc84b71
parent9a6908c9dfc031515ac9eefe34231ceb002ae43c (diff)
downloadaur-2e5f8c695846249a2fa4b1018442d0d8ba37a9a0.tar.gz
enable CGO, tighten required go compiler version, require fuse3 headers
-rwxr-xr-x.SRCINFO3
-rwxr-xr-xPKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c21ce8252cb..4751fddc199d 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,10 @@ pkgbase = singularity-ce
url = https://github.com/sylabs/singularity
arch = x86_64
license = GPL2
+ makedepends = fuse3
makedepends = git
depends = cryptsetup
- depends = go>=1.17
+ depends = go>=1.20
depends = libseccomp
depends = squashfs-tools>=4.3
optdepends = libnvidia-container-tools: use nvidia-container-cli for GPU setup (experimental)
diff --git a/PKGBUILD b/PKGBUILD
index 425d6567037a..bc54a252c276 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,8 +23,8 @@ backup=(
'etc/singularity/network/40_fakeroot.conflist'
'etc/singularity/seccomp-profiles/default.json'
)
-depends=('cryptsetup' 'go>=1.17' 'libseccomp' 'squashfs-tools>=4.3')
-makedepends=('git')
+depends=('cryptsetup' 'go>=1.20' 'libseccomp' 'squashfs-tools>=4.3')
+makedepends=('fuse3' 'git')
optdepends=('libnvidia-container-tools: use nvidia-container-cli for GPU setup (experimental)')
provides=('singularity-container')
conflicts=('singularity-container')
@@ -36,6 +36,7 @@ b2sums=('af1f717bbfe09f8d392ce3e2c5cecc462359856a735fb9f07e8245dc75d2cdde5069aeb
build() {
cd $pkgname-$pkgver
+ export CGO_ENABLED="1"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"