summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2023-02-10 15:02:48 +0100
committerMarco Rubin2023-02-10 15:02:48 +0100
commitce1433751b6750546c9f54d47f79306e91d08d4c (patch)
treea4a46c91e8e1a750e43aec6e61642e880a6e933c
parent492bbef980951bc43fcb0e38a9861d3b8ee2f2d8 (diff)
downloadaur-ce1433751b6750546c9f54d47f79306e91d08d4c.tar.gz
Reproducibility
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1be88a145ce..7f370da68962 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = singularity-ce
pkgdesc = An open source container platform designed to be simple, fast, and secure.
pkgver = 3.11.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sylabs/singularity
arch = x86_64
license = GPL2
@@ -28,7 +28,7 @@ pkgbase = singularity-ce
backup = etc/singularity/seccomp-profiles/default.json
source = https://github.com/sylabs/singularity/releases/download/v3.11.0/singularity-ce-3.11.0.tar.gz
source = tmpfiles.conf
- sha256sums = 45c297f05065c7c920898af37acb781070b2330f141d7a566073197801577753
- sha256sums = 5cd82a6d9aa8232242b6ed7e803c4b4fb497da8b8d506b1f6fc3454b88b73d32
+ b2sums = 52ee19e1fa768d93567cc93cf8bc2a0de60f683436b2dafcc389de7ad96e36d414996ad8def68023855f186d0d1d095cc59d3da6daaba4ae608bb79868d6ff71
+ b2sums = 4d4386ca622fdf5f7c9ac23fd8dd5b18592b27b246478f3755262aceb758e52f1a9ff5d63ef76701b31fd6b7d91ef3978d9a35bc14e6478baee08add6a404891
pkgname = singularity-ce
diff --git a/PKGBUILD b/PKGBUILD
index 66017c7b7418..4f3834da8ee3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=singularity-ce
pkgver=3.11.0
-pkgrel=1
+pkgrel=2
pkgdesc='An open source container platform designed to be simple, fast, and secure.'
arch=(x86_64)
url='https://github.com/sylabs/singularity'
@@ -29,8 +29,8 @@ provides=('singularity-container')
conflicts=('singularity-container')
source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
'tmpfiles.conf')
-sha256sums=('45c297f05065c7c920898af37acb781070b2330f141d7a566073197801577753'
- '5cd82a6d9aa8232242b6ed7e803c4b4fb497da8b8d506b1f6fc3454b88b73d32')
+b2sums=('52ee19e1fa768d93567cc93cf8bc2a0de60f683436b2dafcc389de7ad96e36d414996ad8def68023855f186d0d1d095cc59d3da6daaba4ae608bb79868d6ff71'
+ '4d4386ca622fdf5f7c9ac23fd8dd5b18592b27b246478f3755262aceb758e52f1a9ff5d63ef76701b31fd6b7d91ef3978d9a35bc14e6478baee08add6a404891')
prepare() {
cd $pkgname-$pkgver
@@ -57,7 +57,8 @@ build() {
--prefix="/usr" \
--libexecdir="/usr/lib" \
--sysconfdir="/etc" \
- --localstatedir="/var/lib"
+ --localstatedir="/var/lib" \
+ --reproducible
make -C builddir
}