summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2020-06-06 01:08:40 +0200
committerLone_Wolf2020-06-06 01:08:40 +0200
commit8903b1249aff747d295c9a17a39358c2a41b86d1 (patch)
tree33e5d735413a936406aa61289618cbe79600b141
parent5ce90513ae799a2502a55150505406b12255e01a (diff)
downloadaur-8903b1249aff747d295c9a17a39358c2a41b86d1.tar.gz
adjusted to build latest trunk using python3 & python-setuptools
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD64
-rw-r--r--singularity-git3
-rw-r--r--singularity-git.desktop10
4 files changed, 36 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5af3f56a2c01..710378842b4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,21 @@
-# Generated by mksrcinfo v8
-# Mon Jan 25 15:39:11 UTC 2016
pkgbase = singularity-git
pkgdesc = Strategy game - simulation of true AI, git version
- pkgver = r1050.cc9f6ac
- pkgrel = 3
+ pkgver = r1887.c91df89
+ pkgrel = 1
url = http://emhsoft.com/singularity/index.html
arch = any
license = GPL2
license = custom
makedepends = git
- depends = python2
- depends = python2-pygame
- depends = sdl_image
- depends = sdl_mixer
- depends = python2-numpy
+ makedepends = python-setuptools
+ depends = python-pygame
+ depends = python-numpy
+ depends = python-polib
+ conflicts = singularity
source = git+https://github.com/singularity/singularity
- source = http://www.emhsoft.com/singularity/endgame-singularity-music-007.zip
- source = singularity-git
- source = singularity-git.desktop
+ source = git+https://github.com/singularity/singularity-music.git
+ md5sums = SKIP
md5sums = SKIP
- md5sums = 36ab600d1f6df24e3550b37289cc7710
- md5sums = 1ebf352cb93b5368599ab6c631bf1e79
- md5sums = 1a126f469ea03816a3279ad8b68d558d
pkgname = singularity-git
diff --git a/PKGBUILD b/PKGBUILD
index 3287bf579472..67802d09465d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,48 @@
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Contributor: Lone_Wolf <lonewolf@xs4all.nl>
+# Maintainer: Lone_Wolf <Lone_Wolf@klaas-de-kat.nl>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: sausageandeggs <s_stoakley at hotmail.co.uk>
pkgname=singularity-git
_pkgname=singularity
-pkgver=r1050.cc9f6ac
-pkgrel=3
+pkgver=r1887.c91df89
+pkgrel=1
pkgdesc="Strategy game - simulation of true AI, git version"
arch=('any')
url="http://emhsoft.com/singularity/index.html"
license=('GPL2' 'custom')
-depends=('python2' 'python2-pygame' 'sdl_image' 'sdl_mixer' 'python2-numpy')
-makedepends=('git')
-source=("git+https://github.com/singularity/singularity"
- "http://www.emhsoft.com/singularity/endgame-singularity-music-007.zip"
- "singularity-git"
- "singularity-git.desktop")
-md5sums=('SKIP'
- '36ab600d1f6df24e3550b37289cc7710'
- '1ebf352cb93b5368599ab6c631bf1e79'
- '1a126f469ea03816a3279ad8b68d558d')
-
+depends=('python-pygame' 'python-numpy' 'python-polib')
+makedepends=('git' 'python-setuptools')
+conflicts=('singularity')
+source=( "git+https://github.com/singularity/singularity"
+ "git+https://github.com/singularity/singularity-music.git"
+)
+md5sums=('SKIP' 'SKIP')
+
pkgver() {
- cd "${_pkgname}"
+ cd $_pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-
-
-prepare() {
- cd "${_pkgname}"
- sed -i 's|/usr/bin/env python|/usr/bin/env python2|g' "code/singularity.py"
+build() {
+ cd $_pkgname
+ python setup.py build
}
package() {
- cd "${_pkgname}"
-
- # install game
- install -Dm644 singularity.py ${pkgdir}/usr/share/${pkgname}/singularity.py
- cp -R code data "${pkgdir}/usr/share/${pkgname}/"
- cp -R "${srcdir}/endgame-${_pkgname}-music-007" "${pkgdir}/usr/share/${pkgname}/music"
+ cd $_pkgname
- # install shell script
- install -Dm755 "${srcdir}/singularity-git" "${pkgdir}/usr/bin/singularity-git"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ # music
+ cp -R "$srcdir"/singularity-music/music "$pkgdir"/usr/lib/python3.8/site-packages/singularity/music
+
+
# desktop file
- install -Dm644 "${srcdir}/singularity-git.desktop" "${pkgdir}/usr/share/applications/singularity-git.desktop"
+ install -Dm644 singularity.desktop "$pkgdir"/usr/share/applications/singularity.desktop
# license: code is GPL2, but data & music fall under other licenses
- install -Dm644 README.txt "${pkgdir}/usr/share/doc/${pkgname}/README.txt"
- install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
- ln -s "${pkgdir}/usr/share/doc/${pkgname}/README.txt" "${pkgdir}/usr/share/licenses/${pkgname}/README.txt"
-
- python2 -m compileall "${pkgdir}/usr/share/${pkgname}"
- python2 -O -m compileall "${pkgdir}/usr/share/${pkgname}"
+ install -Dm644 README.txt "$pkgdir"/usr/share/doc/$pkgname/README.txt
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname/
+ install -m644 LICENSE.* "$pkgdir"/usr/share/licenses/$pkgname/
}
-# vim: sw=2:ts=2 et:
+
diff --git a/singularity-git b/singularity-git
deleted file mode 100644
index 267385f0229b..000000000000
--- a/singularity-git
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd /usr/share/singularity-git
-exec python2 singularity.py "$@"
diff --git a/singularity-git.desktop b/singularity-git.desktop
deleted file mode 100644
index c8ebc0500f38..000000000000
--- a/singularity-git.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=Endgame: Singularity
-Comment=Simulation of true AI
-Icon=/usr/share/singularity-git/data/images/icon.png
-Exec=/usr/bin/singularity-git
-Terminal=false
-StartupNotify=false
-Categories=Game;Simulation;