summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2015-06-08 14:13:29 +0300
committerGordonGR2015-06-08 14:13:29 +0300
commit2d6e0ac427776aa361cbb949c6636337fbe5b4fb (patch)
tree22fdd25057ae768d6af2d7769d0c82a4d4b68851
downloadaur-2d6e0ac427776aa361cbb949c6636337fbe5b4fb.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD63
-rw-r--r--singularityviewer.desktop10
-rw-r--r--singularityviewer.launcher5
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..644829312b42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = singularityviewer
+ pkgdesc = An exciting client for Second Life (secondlife) and OpenSim (opensimulator), which combines the look and feel of Viewer 1.23 with the latest and greatest of available technology.
+ pkgver = 1.8.6.6157
+ pkgrel = 1
+ url = http://www.singularityviewer.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = apr-util
+ depends = gtk2
+ depends = libgl
+ depends = libidn
+ depends = libjpeg-turbo
+ depends = mesa
+ depends = nss
+ depends = sdl
+ depends = glu
+ depends = pangox-compat
+ optdepends = libpulse: for PulseAudio support
+ optdepends = alsa-lib: for ALSA support
+ optdepends = nvidia-utils: for NVIDIA support
+ optdepends = flashplugin: for inworld Flash support
+ optdepends = gstreamer0.10: for video support, may need good, bad and ugly plugins
+ optdepends = lib32-freealut: for OpenAL support
+ source = https://bitbucket.org/SingularityViewer/singularityviewer/downloads/Singularity--1.8.6.6157.tar.bz2
+ source = singularityviewer.desktop
+ source = singularityviewer.launcher
+
+pkgname = singularityviewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a648aa191d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: GordonGR <ntheo1979@gmail.com>
+
+pkgname=singularityviewer
+pkgver=1.8.6.6157
+pkgrel=1
+pkgdesc="An exciting client for Second Life (secondlife) and OpenSim (opensimulator), which combines the look and feel of Viewer 1.23 with the latest and greatest of available technology."
+url="http://www.singularityviewer.org/"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('apr-util' 'gtk2' 'libgl' 'libidn' 'libjpeg-turbo' 'mesa' 'nss' 'sdl' 'glu' 'pangox-compat')
+optdepends=('libpulse: for PulseAudio support' 'alsa-lib: for ALSA support' 'nvidia-utils: for NVIDIA support' 'flashplugin: for inworld Flash support' 'gstreamer0.10: for video support, may need good, bad and ugly plugins' 'lib32-freealut: for OpenAL support')
+source=( "https://bitbucket.org/SingularityViewer/singularityviewer/downloads/Singularity-$CARCH-$pkgver.tar.bz2"
+ "singularityviewer.desktop"
+ "singularityviewer.launcher")
+
+if [ "$CARCH" = "i686" ]; then
+md5sums=('d2ef47e3a52b92afa0a979dfbe2d9966'
+ '21b1e68507a1dd851da8ef7d766afe58'
+ 'eb596f5cf7b6f2d0c55c0082fb99a905')
+elif [ "$CARCH" = "x86_64" ]; then
+md5sums=('5fec78052e9f1a99c0d192658137ee8c'
+ '21b1e68507a1dd851da8ef7d766afe58'
+ 'eb596f5cf7b6f2d0c55c0082fb99a905')
+fi
+
+package() {
+cd $srcdir
+
+# Rename Data Directory
+mv Singularity-$CARCH-${pkgver} singularityviewer
+
+# Install Desktop File
+install -D -m644 $srcdir/singularityviewer.desktop \
+ $pkgdir/usr/share/applications/singularityviewer.desktop
+
+# Install Icon File
+install -D -m644 $srcdir/singularityviewer/singularity_icon.png \
+ $pkgdir/usr/share/pixmaps/singularityviewer.png
+
+# Install Launcher
+install -D -m755 $srcdir/singularityviewer.launcher \
+ $pkgdir/usr/bin/singularityviewer
+
+# Install License file
+install -D -m755 $srcdir/singularityviewer/licenses.txt \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+# Move Data to Destination Directory
+install -d $pkgdir/opt
+mv singularityviewer $pkgdir/opt/
+
+# Change Permissions of files to root:games
+chown -R root:games $pkgdir/opt/singularityviewer
+chmod -R g+rw $pkgdir/opt/singularityviewer
+
+# Make Binary Group-Executable
+chmod g+x $pkgdir/opt/singularityviewer/singularity
+
+# Do not re-register the application with the desktop system at every launch, saves from locally installed desktop files.
+sed -i 's|./refresh_desktop_app_entry.sh|#./refresh_desktop_app_entry.sh|' $pkgdir/opt/singularityviewer/singularity
+rm $pkgdir/opt/singularityviewer/refresh_desktop_app_entry.sh
+
+}
diff --git a/singularityviewer.desktop b/singularityviewer.desktop
new file mode 100644
index 000000000000..30f16f10edf8
--- /dev/null
+++ b/singularityviewer.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Singularity Viewer
+GenericName=A third-party viewer for Second Life (C) and OpenSim grids
+Comment=A third-party viewer for Second Life (C) and OpenSim grids
+Exec=/usr/bin/singularityviewer
+Icon=/opt/singularityviewer/singularity_icon.png
+Terminal=false
+Categories=Game
diff --git a/singularityviewer.launcher b/singularityviewer.launcher
new file mode 100644
index 000000000000..8ab6ce68b091
--- /dev/null
+++ b/singularityviewer.launcher
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd "/opt/singularityviewer/"
+./singularity $*
+exit $?