summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikola Hadžić2019-08-13 23:28:53 +0200
committerNikola Hadžić2019-08-13 23:28:53 +0200
commitdb694ac68c40dff70b606a44bf80a961ef25b70c (patch)
treeb71a11213a4aab6f6a88dacdc86cf99d76f35072
downloadaur-db694ac68c40dff70b606a44bf80a961ef25b70c.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0244f1b94f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sini
+ pkgdesc = Simple INI handling library
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/oktopod11/sini
+ arch = x86_64
+ license = LGPL3
+ options = staticlibs
+ source = https://gitlab.com/oktopod11/sini/raw/master/archive/sini-0.1.tar.gz
+ sha256sums = a3eaf85a219858f40732724644d0f5c7d3d21058135bf808bef88302750e638f
+
+pkgname = sini
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2597be34ebd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Nikola Hadžić <nikola@firemail.cc>
+pkgname="sini"
+pkgver=0.1
+pkgrel=1
+epoch=
+pkgdesc="Simple INI handling library"
+arch=("x86_64")
+url="https://gitlab.com/oktopod11/sini"
+license=("LGPL3")
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=("staticlibs")
+source=("https://gitlab.com/oktopod11/$pkgname/raw/master/archive/$pkgname-$pkgver.tar.gz")
+noextract=()
+sha256sums=("a3eaf85a219858f40732724644d0f5c7d3d21058135bf808bef88302750e638f")
+
+build () {
+ cd "$srcdir/$pkgname/"
+ make build
+}
+
+package() {
+ cd "$srcdir/$pkgname/"
+ make install HEADERDIR="$pkgdir/usr/include/sini/" INSTALLDIR="$pkgdir/usr/lib/"
+ make man MANDIR="$pkgdir/usr/share/man/man3/"
+}