summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Keller2015-09-02 14:01:49 -0400
committerAlexander Keller2015-09-02 14:01:49 -0400
commit546b2d8a7b5a1fd7ee7421abe694dabbdc42fe04 (patch)
tree76fb934a785f3c94b6f166acd6e6472dec18cbcf
parent1baa1a01d2439e9f665ab9ca292246370209afd9 (diff)
downloadaur-546b2d8a7b5a1fd7ee7421abe694dabbdc42fe04.tar.gz
Clone config.h in AUR
-rw-r--r--PKGBUILD1
-rw-r--r--config.h5
-rw-r--r--sinit.install2
3 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74dc8d3d6c0c..50a723478139 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,7 @@ md5sums=('9a15ec492278e2a2b29f8b25eda10286')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ cp "$srcdir/config.h" "config.h"
make
}
diff --git a/config.h b/config.h
new file mode 100644
index 000000000000..c68998706c2b
--- /dev/null
+++ b/config.h
@@ -0,0 +1,5 @@
+/* See LICENSE file for copyright and license details. */
+
+static char *const rcinitcmd[] = { "/bin/rc.init", NULL };
+static char *const rcrebootcmd[] = { "/bin/rc.shutdown", "reboot", NULL };
+static char *const rcpoweroffcmd[] = { "/bin/rc.shutdown", "poweroff", NULL };
diff --git a/sinit.install b/sinit.install
index 20ae18cddd17..994fefecf1df 100644
--- a/sinit.install
+++ b/sinit.install
@@ -1,6 +1,4 @@
post_install() {
- echo "==> config.h in the PKGBUILD directory should be"
- echo " edited to configure sinit."
echo "==> To use sinit, add the following kernel parameter"
echo " in your bootloader's configuration file:"
echo " init=/sbin/sinit"