summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-03-03 16:09:14 +0000
committerAntonio Rojas2017-03-03 16:09:14 +0000
commit55a7c5f177ed5bd8f2012221bcc94e002fe01b0f (patch)
tree3a77fd1c4b8d458e131f98a2b12f9c055b870b64
downloadaur-55a7c5f177ed5bd8f2012221bcc94e002fe01b0f.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bb2235d92c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sink
+ pkgdesc = An offline-caching, synchronization and indexing system for PIM data
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://community.kde.org/KDE_PIM
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = flatbuffers
+ makedepends = libgit2
+ depends = curl
+ depends = kcontacts
+ depends = kasync
+ depends = kimap2
+ depends = lmdb
+ source = https://download.kde.org/unstable/sink/0.1.0/src/sink-0.1.0.tar.xz
+ sha256sums = 04aa9468c72a822fc050b89c13d78651a7a760afef44a3a27a872866842a4fb8
+
+pkgname = sink
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3449ae364e6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=sink
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="An offline-caching, synchronization and indexing system for PIM data"
+arch=(i686 x86_64)
+url="https://community.kde.org/KDE_PIM"
+license=(LGPL)
+depends=(curl kcontacts kasync kimap2 lmdb)
+makedepends=(extra-cmake-modules flatbuffers libgit2)
+source=("https://download.kde.org/unstable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz")
+sha256sums=('04aa9468c72a822fc050b89c13d78651a7a760afef44a3a27a872866842a4fb8')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}