summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Seiler2022-08-28 05:52:23 +0200
committerAlexander Seiler2022-08-28 05:52:23 +0200
commit35cc1e31c4659ce16655bbb27582503ce66f334c (patch)
tree9b6d763f566baa384879f8681312d111f0f808d6
parent4a8835ecf75a37da1f038efa0a58d49e9a08d97f (diff)
downloadaur-35cc1e31c4659ce16655bbb27582503ce66f334c.tar.gz
upgpkg: sioyek 1.5.0-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--mupdf-1.20.patch77
3 files changed, 46 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09b94899cae7..782a56bc776b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sioyek
pkgdesc = PDF viewer for research papers and technical books.
- pkgver = 1.4.0
- pkgrel = 2
+ pkgver = 1.5.0
+ pkgrel = 1
url = https://github.com/ahrm/sioyek
arch = x86_64
license = GPL3
@@ -13,9 +13,9 @@ pkgbase = sioyek
depends = qt5-3d
depends = qt5-base
depends = zlib
- source = sioyek-1.4.0.tar.gz::https://github.com/ahrm/sioyek/archive/v1.4.0.tar.gz
+ source = sioyek-1.5.0.tar.gz::https://github.com/ahrm/sioyek/archive/v1.5.0.tar.gz
source = mupdf-1.20.patch
- sha256sums = 44d49aec28e49bb79c2d0fb7cefd26aecc53b60136bf02dfec9863ac586aacd0
- sha256sums = ab9fdffca70d43f1e6d2ba347c546430a79c51452178f05efb086589e247054b
+ sha256sums = 2d01c757953c3f2d98428376e642d13b8a9edeba8fee506477e8aa178756f16b
+ sha256sums = cd639043d9978a27f8957db59001c846bc6b5190fd08afd9cd8d2d8875b532fa
pkgname = sioyek
diff --git a/PKGBUILD b/PKGBUILD
index 877dd4310c7d..1005ea293557 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander Seiler <seileralex@gmail.com>
pkgname=sioyek
-pkgver=1.4.0
-pkgrel=2
+pkgver=1.5.0
+pkgrel=1
pkgdesc="PDF viewer for research papers and technical books."
arch=('x86_64')
license=('GPL3')
@@ -16,7 +16,7 @@ depends=(
'qt5-base'
'zlib')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz" "mupdf-1.20.patch")
-sha256sums=('44d49aec28e49bb79c2d0fb7cefd26aecc53b60136bf02dfec9863ac586aacd0' 'ab9fdffca70d43f1e6d2ba347c546430a79c51452178f05efb086589e247054b')
+sha256sums=('2d01c757953c3f2d98428376e642d13b8a9edeba8fee506477e8aa178756f16b' 'cd639043d9978a27f8957db59001c846bc6b5190fd08afd9cd8d2d8875b532fa')
prepare() {
cd "$pkgname-$pkgver"
diff --git a/mupdf-1.20.patch b/mupdf-1.20.patch
index 975560d66e78..a77e98bc0b98 100644
--- a/mupdf-1.20.patch
+++ b/mupdf-1.20.patch
@@ -1,7 +1,7 @@
-diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewer/document.cpp sioyek-1.4.0-patched/pdf_viewer/document.cpp
---- sioyek-1.4.0-original/pdf_viewer/document.cpp 2022-07-05 18:02:51.000000000 +0200
-+++ sioyek-1.4.0-patched/pdf_viewer/document.cpp 2022-07-10 04:31:02.640253312 +0200
-@@ -542,14 +542,14 @@
+diff '--color=auto' --unified --recursive --text sioyek-1.5.0-original/pdf_viewer/document.cpp sioyek-1.5.0-patched/pdf_viewer/document.cpp
+--- sioyek-1.5.0-original/pdf_viewer/document.cpp 2022-08-20 16:46:51.000000000 +0200
++++ sioyek-1.5.0-patched/pdf_viewer/document.cpp 2022-08-28 05:37:44.991162090 +0200
+@@ -559,14 +559,14 @@
current_node->title = utf8_decode(root->title);
current_node->x = root->x;
current_node->y = root->y;
@@ -18,40 +18,40 @@ diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewe
}
convert_toc_tree(root->down, current_node->children);
-diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewer/document_view.cpp sioyek-1.4.0-patched/pdf_viewer/document_view.cpp
---- sioyek-1.4.0-original/pdf_viewer/document_view.cpp 2022-07-05 18:02:51.000000000 +0200
-+++ sioyek-1.4.0-patched/pdf_viewer/document_view.cpp 2022-07-10 04:31:53.839132616 +0200
-@@ -1018,7 +1018,7 @@
+diff '--color=auto' --unified --recursive --text sioyek-1.5.0-original/pdf_viewer/document_view.cpp sioyek-1.5.0-patched/pdf_viewer/document_view.cpp
+--- sioyek-1.5.0-original/pdf_viewer/document_view.cpp 2022-08-20 16:46:51.000000000 +0200
++++ sioyek-1.5.0-patched/pdf_viewer/document_view.cpp 2022-08-28 05:38:37.022162775 +0200
+@@ -1050,7 +1050,7 @@
std::optional<PdfLink> pdf_link = current_document->get_link_in_page_rect(get_center_page_number(), line_rects[line_index]);
if (pdf_link.has_value()) {
- auto parsed_uri = parse_uri(pdf_link.value().uri);
+ auto parsed_uri = parse_uri(mupdf_context, pdf_link.value().uri);
- DocumentPos res;
- res.page = parsed_uri.page-1;
- res.x = parsed_uri.x;
-diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewer/main_widget.cpp sioyek-1.4.0-patched/pdf_viewer/main_widget.cpp
---- sioyek-1.4.0-original/pdf_viewer/main_widget.cpp 2022-07-05 18:02:51.000000000 +0200
-+++ sioyek-1.4.0-patched/pdf_viewer/main_widget.cpp 2022-07-10 04:33:51.237849831 +0200
-@@ -136,7 +136,7 @@
+ result.push_back({ parsed_uri.page - 1, parsed_uri.x, parsed_uri.y });
+ return result;
+ }
+diff '--color=auto' --unified --recursive --text sioyek-1.5.0-original/pdf_viewer/main_widget.cpp sioyek-1.5.0-patched/pdf_viewer/main_widget.cpp
+--- sioyek-1.5.0-original/pdf_viewer/main_widget.cpp 2022-08-20 16:46:51.000000000 +0200
++++ sioyek-1.5.0-patched/pdf_viewer/main_widget.cpp 2022-08-28 05:39:56.916162839 +0200
+@@ -151,7 +151,7 @@
void MainWidget::set_overview_link(PdfLink link) {
- auto [page, offset_x, offset_y] = parse_uri(link.uri);
-+ auto [page, offset_x, offset_y] = parse_uri(mupdf_context, link.uri);
++ auto [page, offset_x, offset_y] = parse_uri(mupdf_context, link.uri);;
if (page >= 1) {
set_overview_position(page - 1, offset_y);
}
-@@ -2661,7 +2661,7 @@
+@@ -2841,7 +2841,7 @@
+ open_web_url(utf8_decode(selected_link->uri));
+ }
+ else{
+- auto [page, offset_x, offset_y] = parse_uri(selected_link->uri);
++ auto [page, offset_x, offset_y] = parse_uri(mupdf_context, selected_link->uri);
+ long_jump_to_destination(page-1, offset_y);
+ }
}
- if ((link_index >= 0) && (link_index < static_cast<int>(visible_page_links.size()))) {
- auto [selected_page, selected_link] = visible_page_links[link_index];
-- auto [page, offset_x, offset_y] = parse_uri(selected_link->uri);
-+ auto [page, offset_x, offset_y] = parse_uri(mupdf_context, selected_link->uri);
- long_jump_to_destination(page-1, offset_y);
- }
- }
-@@ -3239,7 +3239,7 @@
+@@ -3452,7 +3452,7 @@
return;
}
@@ -60,9 +60,9 @@ diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewe
// convert one indexed page to zero indexed page
page--;
-diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewer/pdf_renderer.cpp sioyek-1.4.0-patched/pdf_viewer/pdf_renderer.cpp
---- sioyek-1.4.0-original/pdf_viewer/pdf_renderer.cpp 2022-07-05 18:02:51.000000000 +0200
-+++ sioyek-1.4.0-patched/pdf_viewer/pdf_renderer.cpp 2022-07-10 04:34:52.438699545 +0200
+diff '--color=auto' --unified --recursive --text sioyek-1.5.0-original/pdf_viewer/pdf_renderer.cpp sioyek-1.5.0-patched/pdf_viewer/pdf_renderer.cpp
+--- sioyek-1.5.0-original/pdf_viewer/pdf_renderer.cpp 2022-08-20 16:46:51.000000000 +0200
++++ sioyek-1.5.0-patched/pdf_viewer/pdf_renderer.cpp 2022-08-28 05:40:36.068162490 +0200
@@ -315,7 +315,7 @@
const int max_hits_per_page = 20;
@@ -72,19 +72,18 @@ diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewe
if (num_results > 0) {
req.search_results_mutex->lock();
-diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewer/utils.cpp sioyek-1.4.0-patched/pdf_viewer/utils.cpp
---- sioyek-1.4.0-original/pdf_viewer/utils.cpp 2022-07-05 18:02:51.000000000 +0200
-+++ sioyek-1.4.0-patched/pdf_viewer/utils.cpp 2022-07-10 04:36:36.587440044 +0200
-@@ -24,6 +24,8 @@
+diff '--color=auto' --unified --recursive --text sioyek-1.5.0-original/pdf_viewer/utils.cpp sioyek-1.5.0-patched/pdf_viewer/utils.cpp
+--- sioyek-1.5.0-original/pdf_viewer/utils.cpp 2022-08-20 16:46:51.000000000 +0200
++++ sioyek-1.5.0-patched/pdf_viewer/utils.cpp 2022-08-28 05:42:07.857280562 +0200
+@@ -23,6 +23,7 @@
+ #include <qnetworkrequest.h>
#include <qnetworkreply.h>
#include <qscreen.h>
-
+#include <mupdf/pdf.h>
-+
+
extern std::wstring LIBGEN_ADDRESS;
extern std::wstring GOOGLE_SCHOLAR_ADDRESS;
- extern std::ofstream LOG_FILE;
-@@ -106,21 +108,9 @@
+@@ -106,21 +107,9 @@
return range_intersects(rect1.x0, rect1.x1, rect2.x0, rect2.x1) && range_intersects(rect1.y0, rect1.y1, rect2.y0, rect2.y1);
}
@@ -109,9 +108,9 @@ diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewe
}
char get_symbol(int key, bool is_shift_pressed, const std::vector<char>& special_symbols) {
-diff '--color=auto' --unified --recursive --text sioyek-1.4.0-original/pdf_viewer/utils.h sioyek-1.4.0-patched/pdf_viewer/utils.h
---- sioyek-1.4.0-original/pdf_viewer/utils.h 2022-07-05 18:02:51.000000000 +0200
-+++ sioyek-1.4.0-patched/pdf_viewer/utils.h 2022-07-10 04:37:43.601270950 +0200
+diff '--color=auto' --unified --recursive --text sioyek-1.5.0-original/pdf_viewer/utils.h sioyek-1.5.0-patched/pdf_viewer/utils.h
+--- sioyek-1.5.0-original/pdf_viewer/utils.h 2022-08-20 16:46:51.000000000 +0200
++++ sioyek-1.5.0-patched/pdf_viewer/utils.h 2022-08-28 05:42:31.572410725 +0200
@@ -33,7 +33,7 @@
int mod(int a, int b);
bool range_intersects(float range1_start, float range1_end, float range2_start, float range2_end);