summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2022-05-16 14:59:28 +0200
committerStephan Springer2022-05-16 14:59:28 +0200
commitee352b5bb4d7a5efb6c806f156b6c514a16e5fe3 (patch)
tree5ee2d4db63ee0a3975f734f42056e935b3592d7a
downloadaur-ee352b5bb4d7a5efb6c806f156b6c514a16e5fe3.tar.gz
new AUR package for sip 6.5.1, used by qgis-ltr
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4d150eab814
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sip-65
+ pkgdesc = A tool that makes it easy to create Python bindings for C and C++ libraries
+ pkgver = 6.5.1
+ pkgrel = 1
+ url = https://www.riverbankcomputing.com/software/sip/intro
+ arch = x86_64
+ license = custom:"sip"
+ depends = python-toml
+ depends = python-packaging
+ depends = python-setuptools
+ provides = sip
+ conflicts = sip
+ conflicts = sip5
+ replaces = sip5
+ options = debug
+ source = https://pypi.python.org/packages/source/s/sip/sip-6.5.1.tar.gz
+ sha256sums = 204f0240db8999a749d638a987b351861843e69239b811ec3d1881412c3706a6
+
+pkgname = sip-65
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a87570e42771
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*~
+*.log
+sip-*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cfe9ea0d765
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+
+_pkgname=sip
+pkgname=sip-65
+pkgver=6.5.1
+pkgrel=1
+arch=(x86_64)
+pkgdesc='A tool that makes it easy to create Python bindings for C and C++ libraries'
+url='https://www.riverbankcomputing.com/software/sip/intro'
+license=('custom:"sip"')
+depends=(python-toml python-packaging python-setuptools)
+provides=(sip)
+conflicts=(sip sip5)
+replaces=(sip5)
+source=(https://pypi.python.org/packages/source/s/sip/$_pkgname-$pkgver.tar.gz)
+sha256sums=('204f0240db8999a749d638a987b351861843e69239b811ec3d1881412c3706a6')
+options=(debug)
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+}