summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112019-02-13 11:38:20 +0100
committerjose17112019-02-13 11:38:20 +0100
commit61ddd379cd2d3dfc8c41e5dc3eb985952f46b5e2 (patch)
tree0f8828b61d9380a0f410ecf6afa9bc52b8b7bb4a
downloadaur-61ddd379cd2d3dfc8c41e5dc3eb985952f46b5e2.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD79
2 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac540bc92f98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Wed Feb 13 10:36:48 UTC 2019
+pkgbase = sip418
+ pkgver = 4.18.1
+ pkgrel = 1
+ url = http://www.riverbankcomputing.com/software/sip/intro
+ arch = i686
+ arch = x86_64
+ license = custom:"sip"
+ makedepends = python
+ makedepends = python2
+ source = http://sourceforge.net/projects/pyqt/files/sip/sip-4.18.1/sip-4.18.1.tar.gz
+ md5sums = 9d664c33e8d0eabf1238a7ff44a399e9
+
+pkgname = sip418
+ pkgdesc = A tool that makes it easy to create Python bindings for C and C++ libraries (the last version compatible with qt3)
+ depends = glibc
+
+pkgname = python-sip418
+ pkgdesc = Python 3.x SIP bindings for C and C++ libraries (the last version compatible with qt3)
+ depends = sip
+ depends = python
+
+pkgname = python2-sip418
+ pkgdesc = Python 2.x SIP bindings for C and C++ libraries (the last version compatible with qt3)
+ depends = sip
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5389b003e13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: riai <riai@bigfoot.com>, Ben <ben@benmazer.net>
+
+pkgbase=sip418
+pkgname=('sip418' 'python-sip418' 'python2-sip418')
+pkgver=4.18.1
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://www.riverbankcomputing.com/software/sip/intro'
+license=('custom:"sip"')
+makedepends=('python' 'python2')
+source=("http://sourceforge.net/projects/pyqt/files/sip/sip-$pkgver/sip-$pkgver.tar.gz")
+md5sums=('9d664c33e8d0eabf1238a7ff44a399e9')
+
+prepare() {
+ cp -a sip-$pkgver{,-py2}
+}
+
+build() {
+ cd "$srcdir"/sip-$pkgver
+ python configure.py CFLAGS="$CFLAGS" LFLAGS="$LDFLAGS"
+ make
+
+ cd "$srcdir"/sip-$pkgver-py2
+ python2 configure.py CFLAGS="$CFLAGS" LFLAGS="$LDFLAGS"
+ make
+}
+
+package_sip418() {
+ pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries (the last version compatible with qt3)"
+ depends=('glibc')
+
+ cd sip-$pkgver
+ make DESTDIR="$pkgdir" install -C sipgen
+ mv "${pkgdir}/usr/bin/sip" "${pkgdir}/usr/bin/sip418"
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}-418/LICENSE
+}
+
+package_python-sip418() {
+ pkgdesc="Python 3.x SIP bindings for C and C++ libraries (the last version compatible with qt3)"
+ depends=('sip' 'python')
+
+ cd sip-$pkgver
+ make DESTDIR="$pkgdir" install -C siplib
+
+ install -Dm644 sipconfig.py "$pkgdir"/usr/lib/python3.5/site-packages/sipconfig418/sipconfig.py
+ install -Dm644 sipdistutils.py "$pkgdir"/usr/lib/python3.5/site-packages/sipconfig418/sipdistutils.py
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}-418/LICENSE
+
+ install -d "${pkgdir}/usr/lib/python3.7/site-packages/sip418" \
+ "${pkgdir}/usr/include/python3.7m/sip418"
+ mv "${pkgdir}/usr/lib/python3.7/site-packages/sip.so" "${pkgdir}/usr/lib/python3.7/site-packages/sip418/sip.so"
+ mv "${pkgdir}/usr/lib/python3.7/site-packages/sip.pyi" "${pkgdir}/usr/lib/python3.7/site-packages/sip418/sip.pyi"
+ mv "${pkgdir}/usr/include/python3.7m/sip.h" "${pkgdir}/usr/include/python3.7m/sip418/sip.h"
+}
+
+package_python2-sip418() {
+ pkgdesc="Python 2.x SIP bindings for C and C++ libraries (the last version compatible with qt3)"
+ depends=('sip' 'python2')
+
+ cd sip-$pkgver-py2
+ make DESTDIR="$pkgdir" install -C siplib
+
+ install -Dm644 sipconfig.py "$pkgdir"/usr/lib/python2.7/site-packages/sipconfig418/sipconfig.py
+ install -Dm644 sipdistutils.py "$pkgdir"/usr/lib/python2.7/site-packages/sipconfig418/sipdistutils.py
+
+ install -d "${pkgdir}/usr/lib/python2.7/site-packages/sip418" \
+ "${pkgdir}/usr/include/python2.7/sip418"
+ mv "${pkgdir}/usr/lib/python2.7/site-packages/sip.so" "${pkgdir}/usr/lib/python2.7/site-packages/sip418/sip.so"
+ mv "${pkgdir}/usr/lib/python2.7/site-packages/sip.pyi" "${pkgdir}/usr/lib/python2.7/site-packages/sip418/sip.pyi"
+ mv "${pkgdir}/usr/include/python2.7/sip.h" "${pkgdir}/usr/include/python2.7/sip418/sip.h"
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}-418/LICENSE
+}