summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2015-08-24 21:22:26 -0400
committerbrent s2015-08-24 21:22:26 -0400
commit84954303b7c2639ad317ffd4d721d879f2b76750 (patch)
tree28f8f95307068be8fb3927e88bb68efdc2750462
downloadaur-84954303b7c2639ad317ffd4d721d879f2b76750.tar.gz
initial import from AUR3
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD27
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e82170f5d064
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sipcrack
+ pkgdesc = SIPcrack is a SIP protocol login cracker.
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://www.remote-exploit.org/codes_sipcrack.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = http://ftp.de.debian.org/debian/pool/main/s/sipcrack/sipcrack_0.2.orig.tar.gz
+ source = LICENSE
+ md5sums = b9096c8d537fc231c7d74b759831a4c7
+ md5sums = 80f9899bc5977147c1a18108e7d39339
+
+pkgname = sipcrack
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1c2d94f40b07
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,26 @@
+
+Copyright (c) 2007 Martin J. Muench. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+- Redistribution of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+- Redistribution in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+- Neither the name of the author nor the names of its contributors may
+ be used to endorse or promote products derived from this software without
+ specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS `AS IS''
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac9bedf19069
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Evan Teitelman <teitelmanevan@gmail.com>
+# Contributor: Pranay Kanwar <pranay.kanwar@gamil.com>
+
+pkgname=sipcrack
+pkgver=0.2
+pkgrel=1
+pkgdesc="SIPcrack is a SIP protocol login cracker."
+license=(custom)
+url="http://www.remote-exploit.org/codes_sipcrack.html"
+arch=(i686 x86_64)
+
+source=(http://ftp.de.debian.org/debian/pool/main/s/sipcrack/${pkgname}_${pkgver}.orig.tar.gz
+ LICENSE)
+md5sums=('b9096c8d537fc231c7d74b759831a4c7'
+ '80f9899bc5977147c1a18108e7d39339')
+
+build() {
+ cd $srcdir/sipcrack-$pkgver
+ make || return 1
+}
+
+package() {
+ cd $srcdir/sipcrack-$pkgver
+ install -D -m755 sipcrack $pkgdir/usr/bin/sipcrack
+ install -D -m755 sipdump $pkgdir/usr/bin/sipdump
+ install -D -m644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}